[Solved] Can 2.1 SDK work with iPhone 2.0 ?

Discussion in 'iOS Programming' started by say2paul, Sep 16, 2008.

  1. say2paul macrumors newbie

    Joined:
    Sep 16, 2008
    #1
    I am very much confused and even Apple people are not responding for past 5 days.

    I have iPhone 2.0, can you please let me know that I can develop application for iPhone 2.0 using 2.1 SDK ??
     
  2. Sbrocket macrumors 65816

    Sbrocket

    Joined:
    Jun 3, 2007
    Location:
    /dev/null
    #2
    Apple usually takes forever to respond. They're probably swamped.

    You can build for both 2.0 and 2.1 with the 2.1 SDK, yes.
     
  3. say2paul thread starter macrumors newbie

    Joined:
    Sep 16, 2008
    #3
    Thanks bro,

    But why apple have written that 2.1 SDK will work with only 2.1 version of iPhone?
     
  4. Niiro13 macrumors 68000

    Joined:
    Feb 12, 2008
    Location:
    Illinois
    #4
    Because there are a couple of methods removed from the 2.1 SDK...and a whole lot more added. So if you use any of those changed methods, the methods might break the program like 2.1 did for a few of the applications (Last.fm, etc.).
     
  5. say2paul thread starter macrumors newbie

    Joined:
    Sep 16, 2008
    #5
    You mean some new methods are added and few old mehods/api are removed??

    In that case, it would be difficult to develop an application for iPhone 2.0 version.

    I think I should download iPhone 2.0 beta SDK instead..

    What do you suggest!!
     
  6. Cromulent macrumors 603

    Cromulent

    Joined:
    Oct 2, 2006
    Location:
    The Land of Hope and Glory
    #6
    Download the 2.1 SDK and build for the 2.0 iPhone OS.
     
  7. say2paul thread starter macrumors newbie

    Joined:
    Sep 16, 2008
    #7
    Are you sure?

    Have you downloaded 2.1 SDK, I doubt if I can build 2.0 on 2.1 SDK!
     
  8. rendezvouscp macrumors 68000

    Joined:
    Aug 20, 2003
    Location:
    Long Beach, California
    #8
    Yes he’s sure. You build for both in Xcode and the simulator has modes for both.
     
  9. say2paul thread starter macrumors newbie

    Joined:
    Sep 16, 2008
    #9
    Thanks a lot!!

    Love you all, this forum ROCKS!!!
     

Share This Page