Solved? Cannot boot from SSD

Discussion in 'PowerPC Macs' started by ITguy2016, Oct 19, 2016.

  1. ITguy2016 Suspended

    Joined:
    May 25, 2016
    #1
    A little over a week ago I picked up an 1.6GHz PowerMac G5 along with a 22" ACD screen. The system works fine and I am looking to sell it for what I paid for it (I'm starting to get too many PowerMacs). For my own reasons I wanted to keep the 80GB hard disk for my 1.8GHz system so I pulled the SSD out of the 1.8GHz system and installed it in the 1.6GHz. The 1.6GHz system booted from the OS (Leopard) which was already installed on the SSD.

    As someone who does not like to sell Macs with personal information I pulled the SSD, connected it to my PC, and used the manufacturers utility to erase the SSD. I then reinstalled it into the 1.6GHz and proceeded to install a fresh copy of Leopard. Upon returning to the system I found it had boot from the Leopard DVD and was back at the start of the install. Thinking I did something wrong I reinstalled the OS. Again the system restarted from the install media.

    I tried a number of things to troubleshoot this and the only thing I can think of is the SSD is not compatible with this system. I pulled the SSD and installed it in my 2.7GHz system and it booted to the initial configuration after an OS install (meaning the OS had actually installed on the SSD from the 1.6GHz system). Thinking maybe there was a problem with the SATA controller on the 1.6GHz system I installed the hard disk (non SSD) from the 2.7GHz system. To which the system booted right to the desktop.

    It's weird in the 1.6GHz system booted from the SSD the one time and, after being erased, has failed to boot in the 1.6GHz since. It boots fine in the 2.7GHz system and the 2.7GHz systems HD boots fine in the 1.6GHz system. The installer, both Tiger and Leopard, see the SSD when it is installed in the 1.6GHz system. The Disk Utility from the install media, both Tiger and Leopard, sees and can work with the SSD. It just can't boot from the SSD.

    I've attempted to reset the PRAM and also attempted to see it as a bootable device when holding down the Option key...it does not show as a device.

    My conclusion is it's not compatible with the older system but I'm puzzled as to how it booted that one time prior to being erased. Does anyone have any thoughts?
     
  2. Orizence macrumors 6502

    Joined:
    Nov 10, 2014
    #2
    If the SSD is a Sata 3 SSD chances are that it wont work as the Sata bus in the G5 is strictly Sata1. You need to find an older Sata 2 SSD that is compatible with the Sata1 bus. The reason is that most Sata1 SSDs cant make the negotiations for the speed the G5 wants.
     
  3. ITguy2016 thread starter Suspended

    Joined:
    May 25, 2016
    #3
    The drive is an OCZ Agility 3 which I believe is a SATA-III drive. However I should note this drive has been working flawlessly in the 1.8GHz system, which I use fairly regularly, for at least two years. However the 1.8GHz is a 2005 model PowerMac G5 whereas the 1.6GHz is a 2003 era PowerMac. What's puzzling is how it booted with the 1.8GHz OS install on it.

    Additional information. System Profiler sees it. Disk Utility sees it. Even StartUp Disk sees it. All of these from the Tiger installer DVD. When I select the SSD as the startup disk from the installers StartUp Disk option it fails to boot. Weird.
     
  4. flyrod macrumors 6502

    flyrod

    Joined:
    Jan 12, 2015
    #4
    Does it still work in the 1.8GHz system? What file system was it formatted for?
     
  5. ITguy2016 thread starter Suspended

    Joined:
    May 25, 2016
    #5
    That's a good question. It works in the 2.7GHz model which is the same era as the 2.7GHz model so I suspect it will. My intent is to put it in the 1.8GHz system, reinstall the OS on it, and then move it back to the 1.6GHz to see if it boots once again. I'll try to boot it in the 1.8GHz before reinstalling.
     
  6. eyoungren macrumors P6

    eyoungren

    Joined:
    Aug 31, 2011
    Location:
    Phoenix • 85037
    #6
    When you made the original format on the PC was the SSD formatted as APM or MBR?
     
  7. ITguy2016 thread starter Suspended

    Joined:
    May 25, 2016
    #7
    I don't know as I can't recall and I can't check as it's been wiped since then. However I can say it was whatever the default type is for a Leopard install.

    As an update I put the SSD back in the 1.8GHz system and it booted just fine. Installing Leopard on it (current install is Tiger) from the 1.8GHz system...will then move it back to the 1.6GHz system to see if it boots.
     
  8. ITguy2016 thread starter Suspended

    Joined:
    May 25, 2016
    #8
    So I reinstalled Leopard on the SSD while it was installed in the 1.8GHz system. Everything went as expected and on reboot it came up to the welcome screen which appears after an install of Leopard. At this point I powered of the system and moved the drive to the 1.6GHz where it booted off the SSD to the welcome screen.

    I'm not sure what the issue is here but one thing I'm happy about is I am not going crazy thinking the 1.6GHz system booted that one time! With all that said I can't provide an answer as to what the issue is.
     

Share This Page