[SOLVED] Downgrade to 3.1.3 from 4.0b1

Discussion in 'iPod touch' started by palz, Apr 23, 2010.

  1. palz macrumors regular

    Joined:
    Apr 2, 2010
    #1
    I have been running 4.0b1 for some time now, and I want to get back to 3.1.3. So I tried it on windows, and I got locked into DFU mode.

    I tried it on a mac, and it froze during the restore (couldn't figure out how to reboot it for hours :eek:)

    So I am in DFU mode, plugged into my windows machine.
    I used iRecovery, but it doesn't detect my device.
     

    Attached Files:

    • cmd.png
      cmd.png
      File size:
      46.2 KB
      Views:
      76
  2. Lambros macrumors regular

    Joined:
    Feb 24, 2010
    Location:
    Sydney, Australia
    #2
    Try this:

    Turn off your iPhone
    Ensure it is plugged into your computer (and still off)
    Hold on/off for 5 secs
    Continue holding on/off and press and hold home for 10 secs
    Release on/off and continue holding home for about 10 secs (or longer until computer recognises it)
    Next, iTunes should pop-up with a thing saying you are in recovery mode or DFU mode or something
    Now, shift-click restore on iTunes, and select the 3.1.3 firmware and restore to it (might be different to shift-click) on a mac
    Finally, tell me if it worked :D

    Good luck!
     
  3. palz thread starter macrumors regular

    Joined:
    Apr 2, 2010
    #3
    Umm, thats what got it in DFU mode :p but when I tried it on a mac, it said:
    Code:
    Extracting software...
    Verifying iPod restore with Apple... (or Saurik:D)
    Preparing iPod for restore...
    Waiting for iPod...
    Error 1603
    On a PC:
    Code:
    Extracting software...
    Verifying iPod restore with Apple... (or Saurik:D)
    Preparing iPod for restore..
    Error 13 (because of Windows)
    
    Anyway, iRecovery didn't detect my device -- unless there's an other way...
     
  4. Lambros macrumors regular

    Joined:
    Feb 24, 2010
    Location:
    Sydney, Australia
    #4
    I believe I used to have error 1603 or whatever it was when downgrading from 3.0 beta (or something of the like) to 2.2.1 (i think??). Anyway, if I jailbroke my device when the downgrade failed, I think it worked fine after. Try this, it might work. Nothing to lose.
     
  5. palz thread starter macrumors regular

    Joined:
    Apr 2, 2010
  6. palz thread starter macrumors regular

    Joined:
    Apr 2, 2010
    #6
    Come on, I have a freaking bricked ipod... or paperweight right now.

    Can't anyone share their advice?
     
  7. Lambros macrumors regular

    Joined:
    Feb 24, 2010
    Location:
    Sydney, Australia
    #7
    No, you downgrade to 3.1.3. Then, it will come up with the error. Jailbreak with redsn0w as if you were jailbreaking a 3.1.3 device. I'd do this all for you but I dont have 4.0 beta to even try it. I just know this from experience with 3.0 beta. Use redsn0w, not blackra1n. Good luck! (and tell me how it goes)
     
  8. upaymeifixit macrumors 6502a

    upaymeifixit

    Joined:
    Feb 13, 2009
    #8
    What does iRecovery say about it?

    I don't know much (probably not as much as you) about this stuff, but if it helps at all, you could try a guide I wrote about downgrading. Here it is.
     
  9. palz thread starter macrumors regular

    Joined:
    Apr 2, 2010
    #9
    Well, I resolved it!

    Here's how:
    Put it in DFU MODE (not restore mode)
    Selected 3.1.3 ipsw
    Restored (you will get a white screen at a point)
    ----
    Downgraded to 3.1.2
    Jailbroke :cool:
     
  10. tlseverson macrumors newbie

    Joined:
    Jun 25, 2010
  11. upaymeifixit macrumors 6502a

    upaymeifixit

    Joined:
    Feb 13, 2009
    #11
    With google.
     
  12. philosopherdog macrumors 6502a

    philosopherdog

    Joined:
    Dec 29, 2008
  13. liamkp macrumors 68020

    liamkp

    Joined:
    May 29, 2010
    #13
    Quite a powerful resource. :cool:
     

Share This Page