General SOLVED: Greenpois0n RC5 "Failed" Error

sumsh

macrumors newbie
Original poster
Jul 26, 2010
21
0
Ok, for those of you that are trying to use Greenpois0n to jailbreak 4.2.1 and getting the "Failed" error, here's what I did and it worked. NOTE: The steps below assume that Greenpois0n.app is on your Desktop.

1. Make sure you're using Greenpois0n RC5_2
2. Make sure device is connected to your Mac
3. Open Terminal
4. Type "cd Desktop" without quotes and hit enter
5. Type "open Greenpois0n.app/Contents/MacOS/greenpois0n" without quotes and hit enter. A second Terminal window will open and Greenpois0n will start
6. Follow the instructions in Greenpois0n to enter DFU mode and it will jailbreak
7. Once jailbroken, a green "Loader" will be added to your device. This is supposed to allow you to install Cydia, but mine would not. If yours is the same, go to step 8
8. Turn off your device
9. Open Redsn0w 0.9.7b6
10. Make sure the only option checked is "Install Cydia"
11. Follow the instructions in Redsnow
12. Voila! Cydia is installed, and you have an untethered 4.2.1 jailbroken device!
 

MacDiddy

macrumors newbie
Nov 8, 2005
3
0
Thank you SO MUCH for this post. Was pulling out my hair all day trying to jailbreak my iPad and your instructions worked fist time. Even had to re-install Cydia as suggested.
 

dieselb0y

macrumors newbie
Feb 4, 2011
1
0
Ohhhhh yeahhh.... this is working!....wowww...cool

Ohhhhh yeahhh.... this is working!....wowww...cool

Thanks!
 

LucasG

macrumors regular
Aug 4, 2010
186
2
Does this also unlock the phone to use with any carrier or do I have to install redsn0w to do that?
 

amzchhabra

macrumors regular
Jun 22, 2010
124
19
London, UK
ABSOLUTE LEGEND! Well done that man! First time, no problems at all, spent all day restoring, rebuilding my mac, all sorts! come on this forum, see your post, and all done within 10 mins.

many thanks!
 

db67fm

macrumors regular
Jul 5, 2010
172
21
Los Angeles, CA
I am following your instructions and after step 5 am getting a message that says Greenpois0n unexpectedly quit.

When I click on reports it says:

Incompatible library version: greenpois0n requires version 6.0.0 or later, but libcurl.4.dylib provides version 5.0.0

Any ideas? I am running 10.5.8
 

coasterswim

macrumors 6502
Dec 4, 2008
344
0
Also, not sure if this will help anybody:

You have to be connected to the internet to run greenpois0n!

I had completely disconnected from my network because I wanted to upgrade my iPhone 4 while preserving the 01.59.00 baseband and was paranoid. greenpois0n failed a bunch of times before I realized what was going on.
 

sumsh

macrumors newbie
Original poster
Jul 26, 2010
21
0
Hey,

Once Cydia has been installed, can I manually delete "Loader" app from my phone?
Yes. Just open the app, hit the "options" button, hit, "uninstall loader" and close the app. Your device will reboot and it'll be gone.
 

sumsh

macrumors newbie
Original poster
Jul 26, 2010
21
0
Does this also unlock the phone to use with any carrier or do I have to install redsn0w to do that?
It does not unlock the phone. In fact, if you've upgraded to stock 4.2.1, then you've lost your unlock capability, since the new baseband is currently not unlockable. There is a way to install an unlockable baseband using redsn0w, but if you do it, you won't be able to ever install a stock firmware again, or restore to factory default.
 

wbski

macrumors newbie
Dec 9, 2009
4
0
You rule! Worked like a charm after not working the regular way on iPad tethered 4.2.1.
 

modafroman

macrumors member
Sep 27, 2007
67
0
Brisbane, Australia
Also, not sure if this will help anybody:

You have to be connected to the internet to run greenpois0n!

I had completely disconnected from my network because I wanted to upgrade my iPhone 4 while preserving the 01.59.00 baseband and was paranoid. greenpois0n failed a bunch of times before I realized what was going on.
This. I'm using my iPhone tethered to my laptop for internet and I think this is the reason why i keep getting jailbreak failed errors. I've tried it about 100 times (windows version, fyi)... and every time has failed, and i've tried everything that I can find to fix it and nothing.

Does anyone have the cached payload files from a succesful iPhone 4 jailbreak using GP RC5 that I can use to test? They would be "iBSS.n90ap & kernelcache.release.n90"

Anyone have these files that they could upload for me? Thanks :)
 

VinnieB

macrumors newbie
Apr 4, 2010
4
0
Hello! I need a hand!

I've done this Redsn0w method with a few iPod touches and iPhones! However, today I got my first 2nd Gen MC model. When I do all the same thing as I did with the other iPods and iPhones, Redsn0w simply doesn't let me do it, because it doesn't support MC models. I have no idea how to get Cydia onto it, as the Loader server is down!

Any help would be very appreciated.
 

V1RU5

macrumors newbie
Feb 17, 2011
1
0
Passcode

Ok, for those of you that are trying to use Greenpois0n to jailbreak 4.2.1 and getting the "Failed" error, here's what I did and it worked. NOTE: The steps below assume that Greenpois0n.app is on your Desktop.

1. Make sure you're using Greenpois0n RC5_2
2. Make sure device is connected to your Mac
3. Open Terminal
4. Type "cd Desktop" without quotes and hit enter
5. Type "open Greenpois0n.app/Contents/MacOS/greenpois0n" without quotes and hit enter. A second Terminal window will open and Greenpois0n will start
6. Follow the instructions in Greenpois0n to enter DFU mode and it will jailbreak
7. Once jailbroken, a green "Loader" will be added to your device. This is supposed to allow you to install Cydia, but mine would not. If yours is the same, go to step 8
8. Turn off your device
9. Open Redsn0w 0.9.7b6
10. Make sure the only option checked is "Install Cydia"
11. Follow the instructions in Redsnow
12. Voila! Cydia is installed, and you have an untethered 4.2.1 jailbroken device!
Thanks! Now I just need to get past this darn passcode. Could somebody help??
 

alpinadvl

macrumors regular
Jan 24, 2008
127
12
THANK YOU! THANK YOU! THANK YOU!


dont know why opening greenpois0n directly doesnt work, but this does.

I was going CRAZY until I found this !

thank you so much !


(any idea why this works?)
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.