Resolved SOLVED! Hard drive unusable after installing in powered on MBP

Discussion in 'MacBook Pro' started by Diogones, Jan 15, 2014.

  1. Diogones, Jan 15, 2014
    Last edited: Mar 15, 2014

    Diogones macrumors regular

    Diogones

    Joined:
    Dec 23, 2009
    #1
    Hey all,

    I have a 2010 13'' MBP that has a 250GB hard drive, and recently I had a chance to upgrade to a 2010 15'' model. Since the previous owner planned to move his HDD out of the Mac, I would have to install my own HDD. I've nearly filled the drive to capacity, so I decided to upgrade to a bigger hard drive, and then put that in the bigger MBP. I got a 320GB laptop drive, performed a fresh install of Mavericks on it, and during the initial run with Setup Assistant I migrated everything off of the 250 to the new drive. After the setup was complete, I booted into the fresh install with my data to ensure everything was working, and it appeared that it was fine. I then shut off the machine, and disconnected the 320GB from the Mac.

    I opened up the 15'' MBP, removed the prior owner's HDD, and replaced it with my new 320GB HDD. What I didn't know was that the MBP was still powered on: it was simply in sleep mode with the lid closed. I hadn't thought to check to ensure that the Mac was off before I did the drive replacement.

    As a result, when I opened the lid on the Macbook, the machine woke up, and was still displaying his desktop and open applications. I quickly closed out of all the applications and shut the laptop off. When I rebooted, it was as I feared: the machine went straight to the OS X Utilities menu, and when I attempted to repair the drive in Disk Utility, I was warned that the drive couldn't be repaired. The drive also did not appear with the Mac partition in Disk Utility: it was just displayed as disk0s2.

    I've tried repairing the drive with Disk Utility, Disk Warrior, and Drive Genius, and none of them have been able to recover/repair the parition. Is it possible that when I replaced the hard drive while the MBP was still powered on, the current session somehow damaged the hard drive's partition or file table?
     
  2. zipa macrumors 65816

    Joined:
    Feb 19, 2010
    #2
    The hard drive is messed up for certain, no questions about that. The question is whether or not you did some actual physical damage to it by "hot swapping" it? If you can repartition it and do another fresh install you should be ok.
     
  3. Steve121178 macrumors 68040

    Steve121178

    Joined:
    Apr 13, 2010
    Location:
    Bedfordshire, UK
    #3
    If you format the disk and install the OS from scratch you should be good to go.
     
  4. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #4
    Since it was in sleep mode, there really wasn't any power going to the drive. As the other poster mentioned. Boot up using the install discs, reinstall OSX, you may be able to do an "upgrade" and retain your information. If that fails then you'll need to reformat and reinstall :(

    If you're concerned about losing your data in the drive, then get an external drive cage and put that drive in there to back it up
     
  5. Alrescha macrumors 68020

    Joined:
    Jan 1, 2008
    #5
    Yes. For future reference, I think the only way of recovering from this error would have been to immediately shut off the laptop by holding down the power button until it turned off.

    A.
     
  6. zipa macrumors 65816

    Joined:
    Feb 19, 2010
    #6

    Probably would not have mattered, since there would have been lots of write operations performed by then already. But yea, that would have at least improved the chances...
     
  7. Diogones thread starter macrumors regular

    Diogones

    Joined:
    Dec 23, 2009
    #7
    Solved!

    Hey all,

    Thanks for the prompt and helpful replies!

    As several of you have already suggested, I ended up having to simply reformat and reinstall OS X on the disk. Even after I shut off the Mac when I had swapped the drive, the partition was damaged, and the system couldn't be recovered. I simply repeated the Migration Assistant process after the initial install, and everything seems to be working good.

    Whenever one is swapping drives between two Macbooks (or any computers, for that matter) always remember to check that both Macs are powered off first. I know it seems obvious, but its easy to forget if the laptop lid is closed and one hasn't checked the pulsating light on the front. Lesson learned!
     

Share This Page