[SOLVED] HELP ME! my macintosh HD access problem

Discussion in 'MacBook Pro' started by washaq, Feb 24, 2012.

  1. washaq, Feb 24, 2012
    Last edited: Feb 24, 2012

    washaq macrumors newbie

    Joined:
    Feb 24, 2012
    #1
    hi guys, im new here, i made a terrible mistake, i changed my macintosh HD permission, i changed Everyone's access type to no access, i cannot open any any app, actually i cannot do anything, i've restarted and hold option key, choosed recover hd and choosed disk utilities then repaired disk permissions after all i restart the Mac and see nothing happens it doesnt even start anymore, im so screwed up all my job is in the Mac, can you help me please, im lion user dont exactly remember the version may be 10.7.2 and i dont have lion cd/dvd everything is in macintosh HD.
     
  2. washaq thread starter macrumors newbie

    Joined:
    Feb 24, 2012
    #2
    it was urgent, and i see no answer so i reinstalling the lion, it will take 2 hours at least, i hope it will solve my problem because i searched every where even in this forum none of the solutions helped me.
     
  3. washaq thread starter macrumors newbie

    Joined:
    Feb 24, 2012
    #3
    Solved

    guys i solved the problem after re-installation is corrupted, here is how i solved my problem:

    1) Boot into single user mode, type mount -uw / and press return

    2) type chmod 775 /Volumes/'Macintosh HD' and press return

    3) type reboot and press return

    to boot in single user mode, restart your mac and hold command(apple) key with s (command+s), your mac will start with terminal.

    source: here
     
  4. SergioHM macrumors newbie

    Joined:
    May 11, 2012
    #4
    macintosh HD no access

    Really thanks!

    You saved me!

    Sergio
    Brazil
     

Share This Page