[SOLVED] How to increase look-up font size in Safari?

Discussion in 'OS X El Capitan (10.11)' started by SmOgER, Jun 28, 2015.

  1. SmOgER macrumors 6502a

    Joined:
    Jun 2, 2014
    #1
  2. TheBuffather macrumors 6502

    TheBuffather

    Joined:
    Jul 19, 2009
    Location:
    Orlando, FL
    #2
    Unless I am mistaken, the font since decreased from DP 1 to DP 2. I noticed that immediately. In any event, I don't know of a way to change this.
     
  3. SmOgER thread starter macrumors 6502a

    Joined:
    Jun 2, 2014
    #3
    It's sad, and I can't think of a single reason why would they need to make that text microscopic in the first place.
     
  4. MikhailT macrumors 601

    Joined:
    Nov 12, 2007
    #4
    @SmOgER, file a bug report. I did as well, I can't see these smaller fonts well. The font size in Yosemite was perfect.

    I think the problem is that they chose a thin font that makes it look smaller as well. When choosing a thin font, you should increase its size to remain its readability.
     
  5. SmOgER, Jul 5, 2015
    Last edited: Jul 5, 2015

    SmOgER thread starter macrumors 6502a

    Joined:
    Jun 2, 2014
    #5
    Okay I found a fix. :)

    ~/Library/Preferences
    com.apple.Safari.plist

    change WebKitMinimumFontSize from 0 to 15 (or the size you prefer)
    works like a charm!

    [​IMG]
     
  6. crapix macrumors newbie

    crapix

    Joined:
    Jul 6, 2015
    #6
    I found no WebKitMinimumFontSize key in the plist
     
  7. crapix macrumors newbie

    crapix

    Joined:
    Jul 6, 2015
    #7
    I use look up to find definition of word a lot. However the dp2 version's look up font size is extremely small
     
  8. Bruno09 macrumors 68020

    Joined:
    Aug 24, 2013
    Location:
    Far from here
    #8
    Can't you do this from Safari / Preferences / Advanced : Accessibility : "Never use font size smaller than..." ?
     
  9. Shirasaki macrumors 603

    Shirasaki

    Joined:
    May 16, 2015
    #9
    I have seen this as well.
    And, if there is a post in "El Capitan all little things" thread? Or bug report thread?
     
  10. KALLT macrumors 601

    Joined:
    Sep 23, 2008
    #10
    Should be the same setting, yes.
     
  11. SmOgER, Jul 6, 2015
    Last edited: Jul 6, 2015

    SmOgER thread starter macrumors 6502a

    Joined:
    Jun 2, 2014
    #11
    It's in there. 2 keys below WebGrammarCheckingEnabled

    But if it truly isn't, then simply create it.


    No.
    This would affect the view of the webpage itself and would basically just mess it up and make everything look horrendous. It has nothing to do with solving the issue in question.
     
  12. MikhailT, Jul 6, 2015
    Last edited: Jul 6, 2015

    MikhailT macrumors 601

    Joined:
    Nov 12, 2007
    #12
    Dude, it's the same thing. The fact it says com.apple.Safari.plist should've told you that.

    Many apps or widgets uses the same WebKit framework that Safari also uses and if you change the setting in Safari, it can affect these apps as well. Because this is an accessibility option, Apple is probably telling Lookup to read the Safari plist for the size.

    In fact, just change it in Safari and you'll see the number changed in the plist file as well.

    0 means the option is turned off in Safari. Enable it and change it to 12 in Safari, changes it to 12 as well in the plist.

    Here's the GIF:

    [​IMG]
     
  13. Bruno09 macrumors 68020

    Joined:
    Aug 24, 2013
    Location:
    Far from here
    #13
    Yes exactly.
     
  14. SmOgER, Jul 6, 2015
    Last edited: Jul 6, 2015

    SmOgER thread starter macrumors 6502a

    Joined:
    Jun 2, 2014
    #14
    You are wrong.

    It does change from the GUI, but in GUI there is the global setting which affects several keys related to the font size, therefore the end result is that you won't be able to see ANY fonts smaller than that number.

    Now my solution is isolated mainly to the lookup popout:

    [​IMG]




    1. Safari GUI option remains disabled.
    2. Unlike the GUI option, webpage fonts remain MUCH smaller than 26 (used it that big to make it even more obvious) maintaining their original scale.
    3. look-up description is just about the only thing which gets affected.

    If I was to set ~26px as a minimum font size in Safari preferences, you wouldn't see any text in website screenshot smaller than the font size in that look-up description.

    Now try to set global minimum font size ~26px in Safari GUI and see for yourself how awful it would look like:

    [​IMG]
     
  15. SmOgER, Jul 6, 2015
    Last edited: Jul 6, 2015

    SmOgER thread starter macrumors 6502a

    Joined:
    Jun 2, 2014
    #15
    And how exactly have you concluded this? It's funny how many people can arrive at wrong conclusion based on one comment even without trying it themselves.

    EDIT: No offence, but next time I will think twice before sharing what solved my problem. To be honest, I have better things to do than trying to prove that what works - works to those who didn't bother to even try it in the first place.
     
  16. adrianlondon macrumors 6502

    Joined:
    Nov 28, 2013
    Location:
    Switzerland
    #16
    You can just add it. Ignore the comments above about changing the font size in accessibility as that changes more than just the lookup size and hence those comments are not useful.
     
  17. KALLT macrumors 601

    Joined:
    Sep 23, 2008
    #17
    You are both right and wrong. It's true that enabling the setting in Safari will also affect the Lookup font size. However, when you set it to 10 or 11 or even 12, you will unlikely affect the layout of most websites and even if it does, when the font size is too small for you in Lookup then it is most likely too small on webpages too. When I set it to 12 on this particular page, only the buttons underneath each post will become slightly bigger. Thus there is probably a good reason to stick with the Safari option anyway, unless you want to use a very large font size for Lookup.

    I recommend using Terminal instead, it's a neater option and quicker for you. Open the Terminal app (just look for it in Spotlight) and type in:
    Code:
    defaults write com.apple.safari WebKitMinimumFontSize -int 11
    Or any other font value. This will create the preference key/value pair for you.
     
  18. crapix macrumors newbie

    crapix

    Joined:
    Jul 6, 2015
    #18
    nothing happened
     
  19. KALLT macrumors 601

    Joined:
    Sep 23, 2008
    #19
    You won't get a confirmation. But you can type the following to verify whether the key (now) exists:
    Code:
    defaults read com.apple.safari WebKitMinimumFontSize
    It should return you the number you entered, i.e. the font size.

    Not sure whether you have to restart anything or whether the change will be applied immediately.
     
  20. adrianlondon macrumors 6502

    Joined:
    Nov 28, 2013
    Location:
    Switzerland
    #20
    The good thing about most terminal commands is that they just do stuff; there's no pop-up or beepy noises or dancing emojis to suggest you did a good thing :) Nah, I know what you mean. You need to reboot.
     
  21. RaphBenYisra'el macrumors newbie

    RaphBenYisra'el

    Joined:
    Jul 18, 2015
    #21
    This didn't work for me, even upon reboot the font size remained the same.

    I'm surprised more people aren't talking about this. It's now such a strain to see the font size in the dictionary popup since updating to El Capitan

    Do not that many people actually use the dictionary popup? I don't understand.
     
  22. KALLT macrumors 601

    Joined:
    Sep 23, 2008
    #22
    I can confirm, it doesn't seem to work in the public beta.
     

Share This Page