[solved]iMac G3 - CD stuck!

Discussion in 'PowerPC Macs' started by Itu, Mar 14, 2009.

  1. Itu macrumors newbie

    Mar 8, 2009
    EDIT: I got it working, this topic may be deleted now.
    Hello, everyone!

    I decided to boot up my old iMac G3 with a slot-loading disk drive. My little sister told me that there's a disk stuck inside. I went to take a look.

    When I turned the power on, I was shocked to hear some awful screeching sounds from the CD drive. The computer repeatedly tried to start spinning the disk in the drive, with no success. I waited for a couple of minutes, and the computer actually recognized the disk. I dragged the icon into the trash bin, and the computer tried to eject the disk. The ejection failed, giving me an error message about a "disk error: could not be ejected". It kept on trying, and still failed.

    Any ideas how I could get it back working?

    I'm going to ban my little sister from the Mac if she doesn't understand how to handle the poor thing properly! ;(

    Thank you for your time.

Share This Page