Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

Diogones

macrumors regular
Original poster
Dec 23, 2009
187
4
I have a Windows 7 PC running the latest version of iTunes (11.0.2.26).

Whenever I inset a CD to import into iTunes, the program doesn't see the CD at all. It doesn't offer to import the CD, it doesn't appear in the sidebar, next to my other devices, nothing.

This only started happening after I updated to iTunes 11. I've tried uninstalling iTunes and re-installing it, and ensuring that the CD's format has iTunes as the default format. I can't even play the CD in iTunes! If I try to drag and drop the tracks from the CD into iTunes, I get a red prohibitory sign.

I've tried this with several CDs, all with the same results. I can import CDs into a friend's Mac running iTunes 11 without any issue. Is this a bug in Windows, or am I missing something?
 
Last edited:

Mike MA

macrumors 68020
Sep 21, 2012
2,064
1,735
Germany

Attachments

  • Unbenannt.JPG
    Unbenannt.JPG
    21.2 KB · Views: 3,372
Comment

Diogones

macrumors regular
Original poster
Dec 23, 2009
187
4
Thanks for your reply Mike!

Yep, I did check my settings, and I've tried all options, including Show CD, and import CD and eject, but no dice.
 
Comment

Mike MA

macrumors 68020
Sep 21, 2012
2,064
1,735
Germany
Yep, I did check my settings, and I've tried all options, including Show CD, and import CD and eject, but no dice.

Than I can only imagine that your PC settings may be the cause (I remember options called Autoplay or something similiar which determine how the computer reacts (and potentially ignores) inserted CDs? But I'm no WIN expert to be honest.
 
Comment

Diogones

macrumors regular
Original poster
Dec 23, 2009
187
4
It could be the Autoplay settings, I'd have to check that.

Yes Smellmett, the disc does appear in My Computer, and it does in fact open so I can view the files. I just can't play any through iTunes
 
Comment

Diogones

macrumors regular
Original poster
Dec 23, 2009
187
4
Well now this is strange: the CD does open up in VLC and in Windows Media Player, without issue. For some reason, iTunes isn't recognizing the CD, and it seems to "block" the disc when I try to play it in the program. I've made sure iTunes is the default player for all applicable audio files, and I even followed the instructions in this helpful iTunes KB article from Apple.

There was an upper filter in the registry, but even after removing that, and rebooting Windows, I had no luck.

I also ran the CD/DVD diagnostic tool in Help--->Run Diagnostics in iTunes, and everything checked out just fine.

I did a repair install of iTunes, but that didn't seem to get it.

I checked a fresh iTunes library in the Guest account in Windows, but it didn't see it either. I'm not sure if a clean install of iTunes would really do the job, and I don't really want to do that either.

I've checked multiple audio discs, just so I could be sure that it wasn't a faulty CD, but it isn't.

iTunes reads the CDs without issue on another machine running Windows 7.

If anyone has any other suggestions, I'd be much obliged; I'm completely stumped!
 
Comment

Diogones

macrumors regular
Original poster
Dec 23, 2009
187
4
Fixed!

Well everyone I figured it out!

It turns out that iTunes on Windows 7 will not recognize any audio CDs because it doesn't "see" the optical drive at all! The only solution I found - thanks to a similar thread on the Apple Support Communities forum - was to change the drive letter on the optical drive. Once the letter is changed from A: to virtually anything else, such as Z:, X:, etc., then iTunes will recognize the disc and work as usual.

It appears this is some sort of bug with iTunes for Windows, and it only occurs if the user changes the optical drive letter to A: or something similar. I noticed this issue only started after I changed the drive letter to A: because I wanted to use the default optical drive assignment, D:, for another internal hard drive.

Once the drive letter is changed, iTunes will see the drive and begin recognizing discs again.

I'm marking the thread as solved. Thanks again to everyone who helped me in this matter! :)
 
Comment

loganjamesalex

macrumors newbie
Jun 15, 2015
1
0
THANK YOU!!! MY CD DRIVE IS A: AND NO ONE COULD TELL ME WHAT WAS WRONG THANK YOU THANK YOU!!!
 
Comment

philgagne

macrumors newbie
Dec 13, 2015
1
1
OMG, thanks so much for this thread! I created an account just to say thanks!

I had setup my CD-DVD-Blu-Ray drive letter to A: like you guys because I needed the D: letter for a hard drive, and I couldn't find any help why iTunes wouldn't recognize my audio CDs...

I changed the drive letter to Z: and restarted iTunes and then iTunes was able to see my CD!!!

:):):):):):):):):):):):):):):):):):):):):):):):):):):):):):):):):):):):):):)
 
  • Like
Reactions: duvetdo
Comment

duvetdo

macrumors newbie
Jan 8, 2017
1
0
OMG, thanks so much for this thread! I created an account just to say thanks!

I had setup my CD-DVD-Blu-Ray drive letter to A: like you guys because I needed the D: letter for a hard drive, and I couldn't find any help why iTunes wouldn't recognize my audio CDs...

I changed the drive letter to Z: and restarted iTunes and then iTunes was able to see my CD!!!

:):):):):):):):):):):):):):):):):):):):):):):):):):):):):):):):):):):):):):)

Me too! Had been doing my head in!!!
 
Comment

Ndee

macrumors newbie
Jan 17, 2017
1
0
Me too! Had been doing my head in!!!

I had this problem too . Drove me crazy . Itunes would not see an audio cd after I rebuilt windows 10 due to a crash and loaded itunes afresh.
I tried every setting possible without any success and wasted several hours. Lastly I changed the DVD drive thinking it was bad hardware and to my amazement it started working. Then I noticed the new DVD drive had installed as F: .... So being a logical type ... I changed the drive letter to A: and presto ..... the fault returned ...
Very Stupid indeed.... So I changed it back to F: and its all working Perfectly

I have 2 CD drives -- The second one is drive B: This one also never worked reading a audio cd to Itunes ... So I changed it to drive G: and .... works perfectly Now

So Looks like drive letter A: and B: dont work on Itunes .... YET they used to in my previous setup

Makes no sense ... what a stupid bug and all the wasted time ...

Then I found this forum and joined just to add this reply
 
Comment

Jacob B

macrumors newbie
Jul 2, 2017
1
0
I had this problem too . Drove me crazy . Itunes would not see an audio cd after I rebuilt windows 10 due to a crash and loaded itunes afresh.
I tried every setting possible without any success and wasted several hours. Lastly I changed the DVD drive thinking it was bad hardware and to my amazement it started working. Then I noticed the new DVD drive had installed as F: .... So being a logical type ... I changed the drive letter to A: and presto ..... the fault returned ...
Very Stupid indeed.... So I changed it back to F: and its all working Perfectly

I have 2 CD drives -- The second one is drive B: This one also never worked reading a audio cd to Itunes ... So I changed it to drive G: and .... works perfectly Now

So Looks like drive letter A: and B: dont work on Itunes .... YET they used to in my previous setup

Makes no sense ... what a stupid bug and all the wasted time ...

Then I found this forum and joined just to add this reply
How do you change the letter from A: to F: or whatever?
 
Comment

Angelabird

macrumors newbie
May 4, 2018
1
0
On my system changed from A to B. Still no joy. Had to change to Z and voila!
[doublepost=1525434489][/doublepost]Hello, how do you change your optical drive? I am not a computer person at all and am having the same issue and have no idea how to change the letter. Thanks
[doublepost=1525436297][/doublepost]
Fixed!

Well everyone I figured it out!

It turns out that iTunes on Windows 7 will not recognize any audio CDs because it doesn't "see" the optical drive at all! The only solution I found - thanks to a similar thread on the Apple Support Communities forum - was to change the drive letter on the optical drive. Once the letter is changed from A: to virtually anything else, such as Z:, X:, etc., then iTunes will recognize the disc and work as usual.

It appears this is some sort of bug with iTunes for Windows, and it only occurs if the user changes the optical drive letter to A: or something similar. I noticed this issue only started after I changed the drive letter to A: because I wanted to use the default optical drive assignment, D:, for another internal hard drive.

Once the drive letter is changed, iTunes will see the drive and begin recognizing discs again.

I'm marking the thread as solved. Thanks again to everyone who helped me in this matter! :)
Hello, how do you change the letter in the optical drive? I am having the same problem and am not a computer person at all and have no idea what to do. Thanks
 
Comment

Matthew_P000111

macrumors newbie
Apr 11, 2019
1
0
OUTSTANDING SOLUTION!!! I'm running Windows 10, with Itunes 12.9, and I had this exact same error.
Granted my DVD/CD RW drive was lettered D:
I changed the Drive to G: re-opened Itunes and it started to import songs!
thanks for the solution!
 
Comment

Staviadaf

macrumors newbie
Apr 7, 2021
1
0
Great post ! I also created an account just to say thank you. 10'000 Kudos !
This post must be ranked #1 in Google results.
:):):):):):):):):):):):):):):):):)

I run ITunes 12.11 and the problem still exists in 2021, 6 years later !!!
ITunes won't work with drive letters A: or B:, choosing anything else fix the problem.

:apple: Apple you must read this thread, stop marketing and make things work correctly on Windows 10 x64 !
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.