(Solved - Long Read) - Don't have "write" access to some folders on my Desktop.

Discussion in 'macOS' started by spinnerlys, Nov 17, 2010.

  1. spinnerlys Guest

    spinnerlys

    Joined:
    Sep 7, 2008
    Location:
    forlod bygningen
    #1
    Hello.

    I have a strange problem, which I don't seem to be able to properly troubleshoot, even with searching the 6U with and without our beloved Free Porn.

    Btw, I solved the problem in between writing this post, but if anyone wants to share some light onto the situation, I invite you to read the following, as I am still flabbergasted by it and want to know, why I can't do what I want to do as laid out in the section below.​



    Problem:
    I have several folders on my Desktop, which seem to not have the proper permissions to be written to or changing its names.
    I took a look at the Sharing & Permissions field in the GET INFO window of several of these folders and seen my user
    Other folders, now and just created to test, do have these two users too, but there is also the "staff" group in there, with Read permissions.
    The other strange thing, the affected folders have also the words "you have custom access" written between the Sharing & Permissions header and the field with the users. The working folders say "You can read and write" instead.

    And another strange thing, it seems to only affect the parent folder and its sub folders, but the actual files inside can have their names changed, though I can't write to them via the application I use, as they are project files and folders for Avid Media Composer 5.0.3.6.

    The files have this as permissions:


    What happened before:
    Last week I did swap my HDD (Momentus 7200.4, 500GB) for an SSD (Vertex 2E, 60GB) and installed Mac OS X 10.6.4 clean onto the SSD. I dragged several folders via Finder from my HDD (now residing in an FW800 enclosure) to the Desktop (on the SSD).
    The folders did work okay, I could read and write to them and I had no problems with them.

    I also made a clone of the SSD via CarbonCopyCloner (CCC) to another HDD
    (that HDD has 500GB with five partitions - two clones of the system, one clone of the installation DVD, one for Time Machine (up to date, only backing up the Users folder) and one for applications' .dmg files and templates)
    to have a backup in case I needed it.

    Then shortly after swapping the HDD for an SSD, Apple released 10.6.5 and I installed it. As I had two partitions on that second HDD reserved for clones, I did clone the update to another partition (one partition has a clone of 10.6.4, the other has a clone of 10.6.5).
    No problems still, but I haven't touched the folders on the Desktop since then to know, if the error started with the update.

    As another problem occurred with the software I use (Avid MC), I decided to go back to 10.6.4, where everything worked, via booting from that 10.6.4 clone and erasing the SSD via Disk Utility (GUID, HFS+ Journaled). Before I erased the SSD, I copied the Desktop folder via Finder to the Momentus HDD (my work HDD now) to copy the data back later.
    After I erased the SSD I ran CCC again to clone the data back.

    Now my software problem seems to be gone, but I have now encountered the previously mentioned "permissions" problem.

    Interludium: I just checked the permissions of the affected folders on the 10.6.4 clone and they are:


    Steps I have taken to try to solve the problem:
    1. Changed permissions for "everyone" to Read & Write via GET INFO. Didn't work, even after unlocking the lock and using the "Apply to enclosed items" selection.

    2. Copied the two of the problematic folders onto a USB stick (FAT32, 4GB) and tried to see, what Mac OS X 10.5.5 (on our work Mac Pro) has to say about it.
    It said in the Sharing & Permissions tab the following:
    and I could change the names of the folders as I wanted to.

    3. Used Terminal and the "chmod" command on one folder, didn't work. Reference
    Code:
    chmod g+r
    Didn't want to test further, as I was a bit afraid of frelling up.

    4. Used the Installation DVD clone and booted into it to "Reset Permissions and ACLs" via the Reset Password utility.
    Didn't work either. Reference

    5. Repaired permissions via Disk Utility.


    Solution:
    While writing this rather lengthy post I came upon the idea, to use Time Machine and restore the folders from there. Hmm. What a brilliant idea, why didn't you come up with it before writing all this down?

    Anyway, I used Finder to browse to the latest backup of these folders and simply copied the folders onto the Desktop. Before I did the copying, I deleted all the files and folders from my Desktop, for which I had to enter my password.
    Now that I restored the proper files from Time Machine, it works.


    But that is not the end:
    I just checked the deleted folders and files in the Trash and came upon some strange sightings.
    I describe it via one example:
    external HDD / Backup / Desktop / Parent folder / sub folder / file

    The Parent folder , while located in the backup location, has the following permissions:
    but when it is located in the Trash:
    /
    The sub folder , while on the backup location:
    but when it is located in the Trash:
    /
    The file, while located in the backup location:
    but when it is located in the Trash:

    I think that is the end, almost anyways, I have yet to write that epilogue.


    Epilogue
    What I learned from this experience, and writing it down surely helped, that simply copying folders from user account to user account, even if they share the same long and short name and password and image and sandwiches, even via an intermediary (external HDD), it can seriously fu permissions bar.

    What I would like to know, and I guess there are many knowledgeable people out there, how can permissions get so confused and why can't I change them back anymore?

    Thanks for reading, sorry for the lack of a screenshot or graphic. Maybe if I feel bored later, I might get onto one. ;)

    Anyway, that was it for today's thread of the months (I do only a thread every 1.359140914 months). Thank you, good night and good luck.
     
  2. Hal Itosis, Nov 18, 2010
    Last edited: Nov 18, 2010

    Hal Itosis macrumors 6502a

    Hal Itosis

    Joined:
    Feb 20, 2010
    #2
    The "custom access" bit suggests the presence of an ACL. Get Info windows in Finder make a feeble effort to GUI-fy all the modes that an object's status may contain. [e.g., not shown under Sharing & Permissions is whether a file is executable or not... and that's just basic POSIX perms. ACLs complicate the possible allowed/denied access picture even further.]

    What i'm saying is that i never rely on Finder's version of the story, and the way to see what's really going on is to look under the hood:

    ls -ldbe@ /path/to/the/item

    I believe that would have revealed some strange (or at least unwanted) ACL on those folders. [the -@ option lists other extended attributes, which are usually harmless... but i have encountered an oddball com.apple.FinderInfo attribute once, whose particular setting did hinder user access (via a busy flag or something).]

    If we know that an item shouldn't have an ACL (or we simply want to remove it anyway), then this is the chmod command to apply first:

    chmod -N /path/to/the/item

    [edit: that -N removes all ACLs from said item. There are also ways to remove/edit ACLs individually, as detailed in the later sections of man chmod.]

    [edit 2: please note that the mere presence of an ACL should not be interpreted as necessarily a bad thing. E.g., that "custom access" description also appears on many folders (such as Documents, Desktop, Music, etc.), because Mac OSX intentionally placed an ACL on those to prevent us from renaming or moving them.]
     

Share This Page