[SOLVED] Mac Mini Ethernet not working

Discussion in 'Mac mini' started by upaymeifixit, Apr 15, 2010.

  1. upaymeifixit macrumors 6502a

    upaymeifixit

    Joined:
    Feb 13, 2009
    #1
    I've been having an annoying problem lately. The ethernet port on my Mac Mini seems to have stopped working. It happened when I was switching routers. Most likely I just unplugged it from the old router, and into the new one. After that, no more connection, nothing changes when I plug something in.

    As far as troubleshooting goes, I've plugged it into other ports, and into my MacBook Air (Just to get a Self assigned IP) and nothing works. I know these ports work with my other computers. I've reset the SMC and PRAM.

    It works in bootcamp so this makes me think it's not hardware. Any other suggestions?
     
  2. Phantom Gremlin macrumors regular

    Joined:
    Feb 10, 2010
    Location:
    Tualatin, Oregon
    #2
    The Ethernet dongle that Apple sells for the Macbook Air works just fine with my Macbook. Maybe it will also work with the mini? Buy one and forget further troubleshooting?

    BTW make sure you have done Software Update.
     
  3. qtx43 macrumors 6502a

    Joined:
    Aug 4, 2007
    #3
    Sorry if you already know this, but since it was while changing your router, the most likely thing is a router problem or a cable problem. Make sure everything's actually plugged in, try a new cable, try resetting the cable modem (probably unplug for a couple of minutes will work), try cloning your computer's MAC address, try resetting the new router (usually a pinhole hold in with a paperclip for a while), try using the old router to see if your ethernet still works... can you access the new router url? i.e. probably 192.168.x.x something or other. It's highly unlikely your computer's ethernet port just stopped working exactly when you changed routers.
     
  4. upaymeifixit thread starter macrumors 6502a

    upaymeifixit

    Joined:
    Feb 13, 2009
    #4
    I forgot about that. I just tried it, and it works. However, there is no chance I am paying for another one of these when mine should work fine. I'm up to date.

    I've already reset the router, unplugged the ethernet, and checked the cables and their connection. Did you read my post? I said I checked to make sure everything else was working with my other computer (and it was). What makes you think this is a hardware thing if it works in bootcamp?

    I have yet to try cloning my MAC address or use the old router (I'll do those tomorrow). No I can't access the router's settings either.
     
  5. upaymeifixit thread starter macrumors 6502a

    upaymeifixit

    Joined:
    Feb 13, 2009
    #5
    I fixed it. Thanks to the two of you who gave me advice. I realized I had changed some settings in the ethernet's advanced settings. Here is what I changed: System/ Preferences > Network > *en0* > Advanced… > Ethernet > Configure: > Automatically. Changing that to automatically solved this. Thanks.
     
  6. thiagobilek macrumors newbie

    Joined:
    Dec 8, 2013
    #6
    I am with this problem too. And "System/ Preferences > Network > *en0* > Advanced… > Ethernet > Configure: > Automatically" didnt worked for me.... ideas??
     

Share This Page