[SOLVED] Mail.app taking ages on "checking for mail" (Gmail via exchange setup)

Discussion in 'iPad' started by Fonzmeister, Jun 8, 2010.

  1. Fonzmeister macrumors member

    Apr 25, 2010
    Portugal - Lisbon

    So, first things first:

    - I'm connected to the Internet (via Wifi, and i tried at home, at work, and via 3G - it's a 64GB 3G);
    - I've followed the instructions on google's help pages (syncing via PUSH using the Exchange account), i googled a lot and found a bunch of people with the same problem, but all the threads were abandoned without a solution;
    - I've got this puppy for 4 weeks, and it worked flowlessly untill 2 days ago when i did a restore (without backup so i could keep the iPad clean and start from scratch - everyone likes to mess around the first few days with software and so on...)
    - Problem happens for at least 12h (maybe too long for a server problem?)
    - English is NOT my first language.

    So i tried this: sent a mail from my work exchange account to my gmail's account. The moment i see the mail on the web app, i see the "checking for mail" message on the ipad, that takes about 30 to 45 seconds to disappear. If i click "Mark as read" on the web, same message appears on the iPad, and so on.

    I've deleted all the settings a couple of times, restarted about 10 times, and nothing. Still stuck with this.

    The question is: it didn't took so long the first time i installed these settings! If i manualy check mail, it also takes a lot in order for effectively check the mail.

    This kind of sucks. Do i need to restore AGAIN? This thing takes ages to copy the 30GB of multimedia i have.

    Thanks in advance!
  2. Fonzmeister thread starter macrumors member

    Apr 25, 2010
    Portugal - Lisbon
    Nailed it!

    Here's the solution for anyone who suffers from the same issue:

    - Restart iPad
    - Delete Exchange Account via Settings Menu
    - Restart iPad
    - Add Exchange Account w/ google settings
    - N'Joy!

    This also solves the problem some people have when mail.app won't download "All Mail" folder (or any other with plenty of e-mails), even if it's instructed to do it!

Share This Page