[SOLVED] MBP A1260 2.5 - Graphic error / crash

Discussion in 'MacBook Pro' started by x30n, Apr 2, 2010.

  1. x30n macrumors newbie

    Joined:
    Apr 17, 2007
    #1
    Fellow Mac Users,

    a week ago a Macians worst nightmare happened to me. My mac died. Well ... one of them. The worst thing is that this MacBook Pro is my only intel machine and therefore my main workhorse. Losing it is rather hard. So I seek for help in my efforts to bring it back to life.

    Symptoms

    The book, when it works, crashes after a while. The screen gets sprinkles with purple fragments, surrounding windows, etc. Sometimes it flickers, etc. This also leads to a complete system crash. Hard reset is the only way out. Yet that does not do the trick.

    When restarted the Screen looks strange. In the left upper corner is a white square about 80x80px in size, below that a black column of about the same width. Right of this the actual light gray screen starts. On top of all this there is always the same greenish pattern to see.

    The apple logo comes, the little circle starts and eventually leads to a gray screen of death. No more booting.

    How it started

    I just came back from India where it was in service for 6 month. Back in Europe it started without problems, behaved normal. One evening the error appeared. I restarted, and ended up on the described boot screen. I restarted again, this time deleting the PRAM by holding P+R. It worked. Well, something worked.

    A few days after that it happened again, and since then its hardly possible to revive it.

    Steps taken so far

    The following steps did not lead to success:

    • PRAM Reset
    • SMC Reset (Removal of all power + holding down on button for 5 secs)
    • Long time power off
    • Complete dis-assembly of the book to clean it, replace the heat sink compund (the one apple used was a mess, t was all over the CPUs!) and ensure proper connectivity of all connectors.
    • Removal of RAM. I have 2x 2GB in there, I removed one and one to see if the problem could be solved like this. It was just a coincidence that one time it booted with only one of the stones. Than it crashed again not too soon after that. That trick didn't work a 2nd time
    • Booting a graphical Linux Live CD like Ubuntu 9.10 or Windows XP. None of them ever make it to life.
    • I did a scan with the TechTool Pro 5. No result. It crashed while it was checking some Filesystem stuff. However the HDD cant be the "aggressor" since it happens to anything.

    What does still work?

    • The Target or Firewire Case Mode still works. By hitting T at startup I can send the book into that mode and connect it to a borrowed iMac to use my sytem. That works without any problems.
    • Booting into Single user Mode (Apple-S)
    • Starting verbose Boot mode (Apple-V) see below for more about that
    • Booting the Gentoo Minimal install disk giving me a text only interface. There are usually red fragments all over the place, but the computer works fine. If there is nothing I can do it could still be used as a server. Yet that would really hurt my feelings :( - Its a Mac, not a Dell!

    The only known way to get it to work

    There is a way to get the book to work. As I mentioned, the Target mode still works. If I turn that on and wait for a while, the floating firewire logo (god bless firewire), which usually get barried below the greenish pattern covering the whole screen, starts to clean out the screen. That means wherever the picture gets changed to show the Firewire Logo. After a while the light gray background comes all back. However there is a frame to it. The pattern stays on all sides of the screen except right. Its about 85px wide on the left and 10-15px high on top and bottom. The right side seems to be invisible due to an offset error of the image or whatever. The Firewire logo partially disappears there.

    Verbose Mode

    I tried to boot in verbose mode only once. The interesting thing was that it stopped booting while telling something about the airport card en1. This is rather strange yet I can't imagine it being the cuase of my problem. After that I switched into Target mode in order to get the system up and this message out. So I did not yet verbose boot it again OR disconnect the wifi unit from the mainboard.

    Conclusion for now

    I'm pretty sure the GPU or a related part suffered some damage. Yet I cant really say for sure. Its rather strange that only graphical stuff seems affected AND that after running for a while in target mode the graphic clears out and the machine can most likely be booted again to run for a while.

    Even so I'm afraid the book has suffered irreparable damage and can only be used in a crippled mode, I call out for help. Please share your thought with me, I'm open to any suggestion you might have for me. There are some extensive tests I want to perform (like unplugging the wifi module or installing different OS) yet I doubt that any of these actions will lead to any success.

    Thank you for sparing some time to read all of this, and let me know if you need some other information which might prove helpful.

    cu
    x
     
  2. x30n thread starter macrumors newbie

    Joined:
    Apr 17, 2007
    #3
    My goodness! You just made my day!

    :D

    Will call them tomorrow. This is so great! What a birthday present! I'm so happy.

    cu
    Roman
     
  3. DewGuy1999 macrumors 68040

    DewGuy1999

    Joined:
    Jan 25, 2009
    #4
    Happy Birthday! :D
     

Share This Page