Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.


macrumors 65816
Original poster
Jun 26, 2010
Hello everyone,

Just in case anyone runs into this error, I wanted to document it.

I have a 4,1 -> 5,1 Mac Pro with an RX 580 and I wanted a fresh install of Mojave on a new SSD. I had been running Mojave for a couple of years and was already running the latest firmware. So this is just a simple OS install.

I followed the usual instructions to create a Mojave Bootable USB Installer. Inserted the USB drive in one of the front USB slots and turned the Mac on. After ~10 minutes all I had was a blank screen, so I pushed the power button to turn it off and suddenly that woke the computer up and I was at the install menu.

I formatted the drive as Mac OS Extended Journaled and then tried to install Mojave on the newly formatted drive. But the SSD was greyed out with this error message:
"You may not install to this volume because the computer is missing a firmware partition."

I wasn't expecting that. After a bit of searching, I couldn't find a definitive answer but decided to reformat the drive as APFS. Luckily, that solved the problem.

Good luck to anyone that runs into this in the future!



macrumors member
Oct 3, 2019
Alexandria, VA
Thanks for this post. I am on a 5,1 cMP running 10.13.6 myself, and I just did my GPU/Boot Room upgrade to 144* to prep for a Mojave install.

All my drives are current HFS+, but in the other Bootrom thread it was mentioned Mojave wouldn't care if my destination drive was still HFS+.

Worst case scenario is I can try ands ee what happens.
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.