[SOLVED] New wireless keyboard - alphanumeric keys not working

Discussion in 'Mac Accessories' started by cleo, Oct 13, 2007.

  1. cleo macrumors 65816

    cleo

    Joined:
    Jan 21, 2002
    Location:
    Tampa Bay Area, FL, USA
    #1
    [SOLVED] (see below for resolution)

    I just bought a new Apple wireless keyboard. Unfortunately, I am posting this with speech recognition software because it will not actually work.

    I was able to pair the keyboard with no problems, and I sent a short email just to try out the feel of the keys. But then I installed the software update. After restarting my computer, the alphanumeric keys on the keyboard will not work. The function keys, modifier keys, and the arrows work fine. It is literally just the numbers, letters, and punctuation keys that are not working.

    I have tried re-pairing the keyboard (strangely, the number keys worked for the pairing process, but stopped working once the keyboard was paired). When that didn't work, I reinstalled the software update (which I downloaded from Apple's Web site), in case it was corrupted the first time. No luck. I also tried cycling the power and installing new batteries.

    This seems to be a software issue, but I have no idea what to do to fix it. Is there any way to uninstall the software update? Has anyone else had this problem?

    SOLUTION:

    After an hour on the phone with a lovely Indian tech named "Dan," it was determined that I had two corrupt preference files. Trashing them solved the problem.

    ~/Library/Preferences/com.apple.systempreferences.plist
    ~/Library/Preferences/com.apple.universalaccess.plist


    Move these to your desktop, restart your machine; if that solves the problem, the two files can be permanently trashed.
     
  2. krisfields macrumors newbie

    Joined:
    Oct 30, 2008
    #2
    Works!

    I also had this perplexing problem and this method solved it.

    Thanks very much!
     

Share This Page