SOLVED: rMBP cannot stay asleep even in deep sleep

Discussion in 'MacBook Pro' started by B74A, Oct 3, 2012.

  1. B74A macrumors member


    Mar 31, 2008
    Asia and Europe
    I never had this with my 2008 MBP, but since a few months, I have had a rMBP:

    It keeps waking from deep sleep

    Since the hard drive is so fast, and I rarely shut it down entirely, I have set the sleep mode to save to disk only (on closing the lid). Works fine, except ... some times when I approach the sleeping rMBP, the fan is running wild, and it is quite hot!

    So I wondered why it would wake up by itself, nothing attached at all, and I think I have narrowed it down to "Wake for WiFi network access" in the Energy Saver settings.

    I found a hint to use terminal to search for what disturbs its sleep, using

    syslog |grep -i "Wake reason"

    and it came up with loads of wakes:

    Oct 4 09:13:01 localhost kernel[0] <Debug>: Wake reason: RTC (Alarm)
    Oct 4 09:14:17 localhost kernel[0] <Debug>: Wake reason: RTC (Alarm)
    Oct 4 09:15:43 localhost kernel[0] <Debug>: Wake reason: RTC (Alarm)
    Oct 4 09:17:08 localhost kernel[0] <Debug>: Wake reason: RTC (Alarm)
    Oct 4 09:18:35 localhost kernel[0] <Debug>: Wake reason: RTC (Alarm)
    Oct 4 09:19:49 localhost kernel[0] <Debug>: Wake reason: RTC (Alarm)
    Oct 4 09:21:11 localhost kernel[0] <Debug>: Wake reason: RTC (Alarm)
    Oct 4 09:22:31 localhost kernel[0] <Debug>: Wake reason: RTC (Alarm)
    Oct 4 09:23:58 localhost kernel[0] <Debug>: Wake reason: EC.LidOpen (User)

    These are just the last few, there are loads of them, the last one being me opening the lid as I heard the fan running (while it should have been sleeping).

    I narrowed this down to Energy Saver, waking the rMBP on WiFi. I guess this is not unique to retina MBPs, but any mountain lion MB?

    The solution is simply to enter System Preferences > Energy Saver > Untick "Wake for WiFi network access"

    I hope this can help others with similar problems.

    Being plugged in, closing the lid, and then it wakes up by itself ... there is not a lot of cooling for it, and it cannot open the lid itself, only turn the fans on!

    When I put my mac into deep sleep, I want it to ... deep sleep! Otherwise I would put it into a power nap, right? :)

    Potentially, if waking while in my bag, it could overheat to an extend to cause a thermal runaway on the battery (I know, it's not plugged in to my bag, but I HAVE FOUND it to be waking, even when unplugged inside my bag). I can assure you, metal lithium batteries that overheat ... are not to be taken lightly! More and more airlines now prohibit or limit the transport of these batteries in bulk, or how many you can carry as a passenger. Loose batteries even more restricted than those inside consoles. And this is not just to annoy passengers, but because of real fire hazards!
  2. B74A thread starter macrumors member


    Mar 31, 2008
    Asia and Europe

    I actually also had to remove the "Enable power nap while plugged into a power adapter" tick ... but NOW it's fine!
  3. case2001 macrumors 6502

    Sep 9, 2010

    Just thought I might bump the thread. I ran across the same issue as above poster. My machine did wake while in sleeve because I just plugged it in to charge while in sleeve and did not disable Power Nap while on line power. After my initial panic and look at iStat, my machine peaked at over 180 Fahrenheit at which point it looks like it shutdown. Much Googling later, I ran across the following at Apple regarding Power Nap:

    "When Power Nap is enabled, your computer may be warm to the touch even if it is sleeping. Power Nap operations will be suspended if your computer exceeds a predefined temperature; your computer will not overheat when using Power Nap."

    So, I guess Power Nap probably shut the machine down well before thermal shut down by the CPU. That makes me feel a whole lot better. The above makes sense, because I know many of us just close the lid and place the machine in a bag. Apple probably included that as a safety mechanism for just the situation I and the above poster encountered.


    But from now on I am still shutting down my machine every time.:)

Share This Page