[SOLVED] Significant touch point offset on ipad 3

Discussion in 'iPad' started by koala1977, Sep 18, 2012.

  1. koala1977, Sep 18, 2012
    Last edited: Sep 19, 2012

    koala1977 macrumors newbie

    Joined:
    Sep 18, 2012
    #1
    Hi guys,

    Problem:
    Everytime I touch, for example, an [x] button to close a tab or window, I need to touch it slightly below by about 1 to 2mm. If I touch on the centre of it (by using stylus), it doesn't work.

    This "issue" seems to be more pronounced in certain applications such as AppStore or Goodreader.

    I had done some searches, and the most useful answer I found is that this might be a feature rather than a hardware issue. See here:automatic Touch point offset problem (iPad) « cocos2d for iPhone

    To reproduce this "issue":
    Open the AppStore
    Click on the search box
    Type anything, in my case I just type "Test"
    There is an [x] appears on the right of search box
    Now, to click on this [x], I have to aim my stylus roughly 1mm below it. It won't work if I hit the stylus on the centre of [x].

    Does anyone else have this issue?

    Many thanks.
     
  2. rodman109110 macrumors 6502

    Joined:
    Jun 7, 2007
    #2
    Use your finger. It's a touch screen.

    In all seriousness it could be a hardware problem. Have you tried restoring the software? I would try that first and if that doesn't work, take it into the apple store and see what they say.

    If its not effecting your use of the iPad significantly I would just deal with it.
     
  3. ActionableMango macrumors 604

    ActionableMango

    Joined:
    Sep 21, 2010
    #3
    I think there is indeed an offset in iOS. I don't have an iPad3, but I've noticed it on my iPhone3G and 4.

    A simple test, and how I first noticed this:
    Place the iDevice flat on a desk.
    Use as normal. Note it works fine.
    Spin the iDevice so it is upside down from you (but don't allow auto-rotate).
    Attempt to use as normal. Everything now misses!

    I have to purposely aim higher (from my point of view) to activate screen controls. This says to me that there is built in offset downward.

    It probably has something to do with the fact that you are seeing and aiming for the LCD surface, but you are actually touching the glass surface above it. And in order to work most accurately in most conditions, it needs that offset.
     
  4. koala1977 thread starter macrumors newbie

    Joined:
    Sep 18, 2012
    #4
    @ActionableMango

    Thanks for the reply - It prompted me to go to the Apple Store today.

    Tested on four ipad3's and some of the ipad2's - Similar behaviour.

    So it appears that this is a feature/intentional. Which makes me feel a little better that at least I can now rest my mind that it is not a hardware fault.
     

Share This Page