[solved]SSH Port Forwarding

Discussion in 'Mac Basics and Help' started by antdgar, May 29, 2008.

  1. antdgar macrumors member

    Joined:
    Oct 5, 2007
    #1
    Hi, I want to get around my ISP's firewall which blocks almost everything. I know I can do thi using SSH and port forwarding.

    I found a software for OS X that gives me the right command:

    Code:
    ssh -N -p 22 -c 3des -D 1080 admin@server -R 31313/localhost/31313
    This works, HOWEVER the remote port forwarding of 31313 does NOT work...

    I want my server to listen on port 31313 for connections, and then forward them to my computer.
    Anyone know how to do this???

    My ISP blocks all incoming connections.

    Thanks.
     
  2. merl1n macrumors 65816

    merl1n

    Joined:
    Mar 30, 2008
    Location:
    New Jersey, USA
    #2
    I need to know more about your setup...

    What server are you referring to? Is this a remote server somewhere else or on your local network?

    SSH uses port 22. Why are you listening on port 31313?

    On your local Mac, do you have the firewall enabled in the Sharing Preferences? if so have you added a rule to open the port for ssh to use Port 22?

    Are you using a router on your local network? Have you done Port forwarding on it for port 22?

    Need this info.
     
  3. ert3 macrumors 6502a

    ert3

    Joined:
    Dec 10, 2007
    #3
    Well thats not exactly true as SSH is per server its not like email where you have to use a certain port as I use 6022 on my server.

    Its a server end change you need to make and before I can tell you how to do that I need to know more about your server.

    To be honest though this sounds like your trying to subvert your school's network in which case I do not recommend you do this as your admins can see what you are doing and will probably block you.
     
  4. antdgar thread starter macrumors member

    Joined:
    Oct 5, 2007
    #4
    Fixed now. But thanks for the replies.

    I just needed to allow GatewayPorts on my linux server, in SSHD_config file.

    I am currently in China and their f***ing firewall is screwing me. Can't wait to go back to UK *sigh*
     

Share This Page