[SOLVED] VPN to Windows server - connects but no data

Discussion in 'macOS' started by thedriver, Oct 7, 2010.

  1. thedriver macrumors newbie

    Joined:
    Oct 7, 2010
    #1
    I've read over a dozen threads with similar issues to this, but have not found an answer so far...

    I have setup a PPTP VPN using the inbuilt client (OSX 10.6.3) to a Windows RRAS server.

    It connects (gets a valid IP from DHCP) and authenticates alright (I can see the logon in the events), but I can't get any data across VPN to the work network. I can't even ping the server I'm connected to (or any others), by hostname (incl FQDN) or IP.

    Other Windows desktops connect to the VPN fine and can see the work network.

    I'm actually trying to Remote Desktop to another server on the work network, but I need connectivity first through the VPN. The Remote Desktop works fine on the LAN, so I assume once the VPN works properly (i.e. I can ping other devices) then Remote Desktop will work also.

    Any help with the VPN would be appreciated.
     
  2. thedriver thread starter macrumors newbie

    Joined:
    Oct 7, 2010
    #2
    Wow!

    Wow... no help.

    Does anyone have anything they can add to this please? I could really use some assistance.
     
  3. RandomKamikaze macrumors 6502a

    RandomKamikaze

    Joined:
    Jan 8, 2009
    Location:
    UK
    #3
    In the Advanced settings for you VPN connection have you got the box ticked to send all the traffic down the VPN?
     
  4. thedriver thread starter macrumors newbie

    Joined:
    Oct 7, 2010
    #4
    VPN Woes

    Thanks Chris, I have tried both out of frustration. Either with or without this option enabled, it makes no difference, I just can't see anything on the work network.
    As a side note on this setting though, it shouldn't matter whether it is enabled or not. Any traffic that is destined for the work network (identified by the IP address and subnet mask) should be forwarded through the VPN tunnel regardless of the setting.
     
  5. thedriver thread starter macrumors newbie

    Joined:
    Oct 7, 2010
    #5
    Solved

    Well the problem is finally solved.

    Go to:
    1. System Preferences
    2. then Network
    3. Click the Cog / Tool menu drop down and select "Set Service Order"
    4. Drag the VPN connection to the top of the list.
    Connect the VPN and it should work. Simple really, but stupid too. I had to pay someone else to help me, now I give it to you free. :D
     
  6. RandomKamikaze macrumors 6502a

    RandomKamikaze

    Joined:
    Jan 8, 2009
    Location:
    UK
    #6
    Sorry for not checking this sooner.

    Glad you got it sorted
     

Share This Page