SOLVED: Windows 7 BSOD after bootcamp drivers install

Discussion in 'Mac Pro' started by slughead, Mar 18, 2012.

  1. slughead, Mar 18, 2012
    Last edited: Mar 19, 2012

    slughead macrumors 68040

    slughead

    Joined:
    Apr 28, 2004
    #1
    MP Hexcore 2010 w/ 5870 & 6870 12gb RAM, OS X lion -- latest bootcamp drivers

    I just installed the latest bootcamp drivers in a previously-working Windows 7 install.

    I immediately started getting CACHE_MANAGER BSOD... Restarted twice and got the same error twice in a row.

    I looked at the log dump and couldn't find anything too suspicious.

    The last time I used Apple's bootcamp drivers was like 2009 and I remember having a ton of problems with AppleHFS because I had a lot of hard drives and some Apple Software RAID. I also noticed some errors having to do with my gigabit card.

    So I booted into safemode w/networking, went into Windows/System32/drivers and deleted AppleHFS and AppleMNT.

    I also went into device manager and had windows "auto update" the gigabit drivers.

    So far no problems. I can't believe Apple still hasn't figured this problem out.
     
  2. DaveF macrumors 6502a

    Joined:
    Aug 29, 2007
    Location:
    NoVA
    #2
    Same problem with a 2007 MacBook Pro, Boot Camp 4, and Windows 7 32 bit.

    Apple Bootcamp drivers installed on a fully updated Win7 system cause it BSOD on boot, every time. I finally worked around it by:
    * Install Win 7 through Bootcamp Assistant, but don't install the Bootcamp-specific drivers
    * Bring Win7 fully up to date (all updates)
    * Create a Restore Point (to be a little safe)
    * Install Bootcamp drivers
    * Boot into OS X
    * Install Tuxera NTFS
    * Rename AppleHFS.sys to AppleHFS.sys.old
    * Boot into Windows
    * Everything should be stable; the one loss is there's no access to the Mac partition anymore
    * Create another Restore Point

    In my situation, AppleMNT.sys isn't a problem so far. And leaving Bootcamp.exe to run at launch in MSCONFIG.exe is also stable.
     
  3. nox-uk macrumors regular

    Joined:
    Apr 11, 2012
    #3
    Theres a thread about this in the bootcamp forum too :)

    I disabled the disks that were in my raid set in device manager to sort mine - it seem (or at least to me) that the files are fine for the most part, but if you have an apple raid set or encryption or something, then that causes the problem.

    Nox
     

Share This Page