Resolved SOLVED! Windows 7 drive won't boot on Snow Leopard

Discussion in 'Windows, Linux & Others on the Mac' started by Diogones, Oct 20, 2011.

  1. Diogones, Oct 20, 2011
    Last edited: Nov 20, 2011

    Diogones macrumors regular

    Diogones

    Joined:
    Dec 23, 2009
    #1
    I have an internal hard drive with Windows 7 Pro x64 installed on it. I know the drive works, because I've booted it up in my PC. However, I have a hard drive dock that I would like to test, so I took the drive out of the PC, put in the dock, and hooked it up via USB to my Intel Mac Mini with Snow Leopard installed on it. The drive mounts normally in SL, and I can see and access all the files just fine. However, when I try to boot to the drive via the USB, it doesn't work. The drive does not appear in the Startup Disk pane (unless I hook the dock to the Mac with Firewire) and when I boot the drive from the Startup Select screen, I get a black screen with the error message, "No bootable device found."

    Now I know I can't boot XP via USB, without modifying it first, but does the same hold true for the WIndows 7 drive? I read the Apple support article which states that only drives that have use the GPT scheme and have 10.4.5 or later installed on it is eligible for booting from a USB drive. I know this is technically an internal drive in a drive dock, but does the Mac still treat it as an external USB drive regardless?
     
  2. balamw Moderator

    balamw

    Staff Member

    Joined:
    Aug 16, 2005
    Location:
    New England
    #2
    Generally so. You just can't boot any Windows from any USB drive on the Mac.

    FireWire or ThunderBolt are just a bit more likely to succeed, but it is still hit or miss.

    B
     
  3. Diogones thread starter macrumors regular

    Diogones

    Joined:
    Dec 23, 2009
    #3
    Thanks for your reply balamw! I realize that now, so I'm marking this thread as solved.
     

Share This Page