SOLVED: Xcode Errors on Startup

Discussion in 'iOS Programming' started by Kglazebrook, Jan 9, 2011.

  1. Kglazebrook, Jan 9, 2011
    Last edited: Jan 9, 2011

    Kglazebrook macrumors newbie

    Jan 9, 2011
    Farmington CT
    DISREGARD! I solved my own problem...

    Hardware: MacBook Pro 8G/2.66GHz Intel Core i7

    Xcode 3.2.5 / iOS SDK 4.2

    My excitement for learning Mac programming is waning as I have re-installed Xcode 30 times and continue to receive the following error:

    Process: Xcode [1017]
    Path: /Developer/
    Version: ??? (???)
    Build Info: DevToolsIDE-17600000~5
    Code Type: X86-64 (Native)
    Parent Process: launchd [150]

    Date/Time: 2011-01-09 13:45:41.389 -0500
    OS Version: Mac OS X 10.6.6 (10J567)
    Report Version: 6

    Interval Since Last Report: 11097 sec
    Crashes Since Last Report: 12
    Per-App Crashes Since Last Report: 6
    Anonymous UUID: 7B40FD53-A449-469B-A222-A6C002C32368

    Exception Type: EXC_BREAKPOINT (SIGTRAP)
    Exception Codes: 0x0000000000000002, 0x0000000000000000
    Crashed Thread: 0

    Dyld Error Message:
    Library not loaded: @rpath/DevToolsFoundation.framework/Versions/A/DevToolsFoundation
    Referenced from: /Developer/
    Reason: image not found

    Binary Images:
    0x7fff5fc00000 - 0x7fff5fc3bdef dyld 132.1 (???) <B536F2F1-9DF1-3B6C-1C2C-9075EA219A06> /usr/lib/dyld

    Model: MacBookPro6,2, BootROM MBP61.0057.B0C, 2 processors, Intel Core i7, 2.66 GHz, 8 GB, SMC 1.58f16
    Graphics: NVIDIA GeForce GT 330M, NVIDIA GeForce GT 330M, PCIe, 512 MB
    Graphics: Intel HD Graphics, Intel HD Graphics, Built-In, 288 MB
    Memory Module: global_name
    AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x93), Broadcom BCM43xx 1.0 (
    Bluetooth: Version 2.3.8f7, 2 service, 19 devices, 1 incoming serial ports
    Network Service: AirPort, AirPort, en1
    Serial ATA Device: Hitachi HTS725050A9A362, 465.76 GB
    Serial ATA Device: MATSHITADVD-R UJ-898
    USB Device: Hub, 0x0424 (SMSC), 0x2514, 0xfd100000
    USB Device: Built-in iSight, 0x05ac (Apple Inc.), 0x8507, 0xfd110000
    USB Device: IR Receiver, 0x05ac (Apple Inc.), 0x8242, 0xfd120000
    USB Device: Hub, 0x0424 (SMSC), 0x2514, 0xfa100000
    USB Device: Internal Memory Card Reader, 0x05ac (Apple Inc.), 0x8403, 0xfa130000
    USB Device: BRCM2070 Hub, 0x0a5c (Broadcom Corp.), 0x4500, 0xfa110000
    USB Device: Bluetooth USB Host Controller, 0x05ac (Apple Inc.), 0x8218, 0xfa113000
    USB Device: Apple Internal Keyboard / Trackpad, 0x05ac (Apple Inc.), 0x0236, 0xfa120000

    I'm a Windows developer by trade and very much a novice to Mac programming.

    Thanks for any feedback!

    Kevin G.
  2. trong.nguyen macrumors newbie

    Feb 27, 2011
    Dear Kglazebrook!

    I am facing with this problem, my MacOS version is Snow Leopard 10.6.6 (bulid: 10J567), my Xcode is 3.2.5 with SDK 4.2. The error "Xcode cannot be openned because of a problem" prevent me from opening this application. Could you please tell us the way you solve this issue? it's really useful with us.

    Thank you so much.


Share This Page