Some Apple apps not working on my watch

Discussion in 'Apple Watch' started by ladytonya, Oct 2, 2017.

  1. ladytonya macrumors 6502a

    Joined:
    Oct 14, 2008
    #1
    Since the last iOS 4 update, neither the Calendar nor the Maps apps work on my watch. I have searched both here and the Apple community forums to no avail.

    I have the Calendar set as a complication on the Modular watch face and it shows the time of my next calendared event. When I click on it for more detail, I get "Restore "Calendar"? You followed a link that requires the app "Calendar", which is no longer on your Apple Watch. You can restore it from the App Store." The only option I have on the watch is "Dismiss". If I go to the main screen, the Calendar icon is there but when I click on it, nothing happens. How do you restore a native Apple app?

    The Maps app is even stranger. On the main screen, it is grayed out like it isn't installed on my watch at all. When I click on it nothing happens. Also, when I use GPS directions in the Maps app on my phone I am getting the haptic signals on the watch but the directions to not appear.

    I have tried rebooting both the watch and the phone, everything in the watch app on my phone looks like it's set up correctly. I have tried resetting the phone. I've basically tried everything but repairing the watch because that it such a PITA, the backups never work or it backs up and has the same problem I was trying to get rid of. Any suggestions or do I just have to suck it up and re-pair the watch and deal with the fallout?
     
  2. sean000 macrumors 68000

    sean000

    Joined:
    Jul 16, 2015
    Location:
    Bellingham, WA
    #2
    Have you forced a hard reboot on both devices by holding both buttons? Sometimes that's the only thing that resolves weird issues for me.

    Both maps and the native calendar are working on my Series 0 watch after updating to OS4.

    I don't think you can remove and restore a native mail app, but at least for the calendar you can remove and re-add calendar accounts.
     
  3. ladytonya thread starter macrumors 6502a

    Joined:
    Oct 14, 2008
    #3
    I’ve tried that already. It’s really strange, not sure what’s going on.
     
  4. technoholic macrumors 6502a

    Joined:
    Mar 20, 2016
    #4
    I had the same issues with some apps, specifically Shazam that I can remember now. Could open the app and it would respond but not actually do anything. Some other apps were behaving similarly, looked like they were installed fine but not working properly. I did a hard reboot earlier and that seemed to work. I think everything is working ok now but haven't tested fully yet.
     
  5. ujjbd16 macrumors newbie

    Joined:
    Apr 24, 2015
    #5
    The Sleep app is not working on my watch. Says it is not authorised and have access to motion data. Not sure what this means.
     

Share This Page

4 October 2, 2017