Some apps won't redownload after restoring to new iPhone?

Discussion in 'iPhone Tips, Help and Troubleshooting' started by anyjungleinguy, Sep 27, 2015.

  1. anyjungleinguy macrumors regular

    Joined:
    Mar 6, 2012
    #1
    After resorting a backup onto my new 6S I've got 3 apps that won't install.

    They just hang on download. Tried rebooting, tired deleting and redownloading but nothing. It's also happening with one app on my dads (different to the apps I'm having a problem with).

    Any ideas? I don't want to set up as new due to losing all my activity and health and fitness stuff for the Watch.
     
  2. Bleh5 macrumors regular

    Joined:
    Jun 28, 2007
    #2
    What worked for me is going into the App Store, going into Purchased, and tapping the download button there.
     
  3. anyjungleinguy thread starter macrumors regular

    Joined:
    Mar 6, 2012
    #3
    Thanks for the suggestion but unfortunately it didn't work.
     
  4. rigormortis macrumors 68000

    rigormortis

    Joined:
    Jun 11, 2009
    #4
    i had some issues. i went to iTunes and deleted the ones i had problems with, and downloaded fresh copies from the purchased screen , and once i did that and did i restore it fixed it

    this was after i tried deleting my .itl and adding the library again

    i tried to download copies to the actual phone from wifi with the theory i could transfer them back to my library, but the restores left my iPhone not being able to be synced or backed up
     

Share This Page