Some bad luck in downloading "Life on Earth" book

Discussion in 'iPad Apps' started by NameUndecided, Jan 21, 2012.

  1. NameUndecided macrumors 6502a

    Mar 28, 2011
    I tried Googling around for anyone having a similar problem with iBooks or app downloading, but I didn't find close enough of a match…

    This is probably more of an iBooks or app store type problem than anything about this specific book. Here's what's happening:

    I tried downloading Life on Earth with iBooks 2 on my iPad 2 the other day when it first launched -- it continually won't go through with the download though, saying "Unable to Download 'E.O. Wilson's Life on Earth' Retry or download later from the store." and I can select either Later or Retry. Whichever option I choose, I'm still stuck with that message and it won't download.

    I've tried downloading the book on my Mac and it will download just fine, but when I transfer it to my iPad, the book icon will show with an almost-completed download progress bar on it, even though the file downloaded completely on my Mac, and has appeared to transfer all the way from my Mac to my iPad. So with this look of not being completely downloaded, I'm still unable to open the book.

    I can download a sample of this book just fine. I've downloaded a sample of another textbook and that works just fine. I've tried downloading this Life on Earth book with as much as about 2.3gb free space available on my iPad. My iPad has also been turned off and restarted a few times over the past couple of days.

    Any help is appreciated. I'm presently without any other ideas on what to try. Thanks for any feedback!
  2. ticuor macrumors newbie

    Jan 22, 2012

    I have the same issue with this textbook download.
    Unable to download it or remove it from the download list.
    The alert keeps poping up every time iBooks started and there's nothing I can do about it.
    So annoing... :mad:

    Anyone else? :confused:
  3. Pton878 macrumors newbie

    Jan 22, 2012
    Same issue!

    I have the same problem, the book won't download at all and the message comes up asking to retry or do it later, it's quite annoying.

    However! There is a way to get rid of the download, view the books in list view in iBooks, then swipe from right to left over the right edge of the download, and a delete button will appear, this will work for all the books as well.

    Having deleted the book, I still get the download error message when I'm in the iBooks store every time i change a page. Anyone have any thoughts???
  4. sheilaef macrumors newbie

    Jan 13, 2008
    SF Bay, CA
    Connect to your computer -

    The file is huge, 965 MB. I couldn't download it using wireless, either (especially with my daughter in the next room watching a TV show stream, and my husband listening to Pandora) I waited and synced to the computer and it downloaded in about 20 minutes to iTunes, then uploaded to my iPad. Make sure you close iBooks and reopen it or the dialog message will still show.
    It's cool. So is the software, iBooks Author. Needs a few tweaks here and there, but if I was a teacher or a student, I'd be pretty happy. Heck this may make me want to go back for my doctorate!

    Now we just need folks who can tape teacher's lectures, pull together or create the supplemental materials (3D images, movies, short widget animation:Ds and even practice tests!) and you can have your university in your hand, along with your songs, your movies and shows, all your social media and the entire internet.

    With each title at ~ 1 GB and larger in size, I think my 16 GB iPad is not long for this world. . .
  5. NameUndecided, Jan 22, 2012
    Last edited: Jan 22, 2012

    NameUndecided thread starter macrumors 6502a

    Mar 28, 2011
    Argh. So lame. Tried copying the book from iTunes to my iPad again, this time it told me it couldn't do it because I didn't have iBooks 2, which I do. After I restarted my iPad, it then appeared to copy over just fine, but it ended up with the download-in-progress bar on the book cover again. I also made sure that I had iBooks closed on my iPad when I transferred it over this time.

    I deleted my copy of the book off of my computer and am re-downloading through iTunes onto my Mac again…

    Still gives the "still downloading" appearance when I copy it to my iPad.

    I think that my iBooks really doesn't like this book for some reason. I would delete and then re-download iBooks 2 altogether, but I don't want to risk having to put back all of the PDFs and stuff that I have in it at this time.

    edit: Oh, goody! My Life on Earth book suddenly turned into a normal icon just about thirty seconds after I posted this. About three or four minutes after it appeared [on my computer's end] to completely copy from iTunes.

    So I guess if you're having a problem similar to what I was having, first connect your iPad to your computer and go to the "Books" section on your iPad within iTunes. Delete any copy of the book that you might still have listed there.

    Download the book to your computer through iTunes.

    Transfer the book from iTunes to your iPad.

    Open iBooks on your iPad and see if it's completely transferred over yet (even if iTunes seems to think that it has).

    If it appears to not be completely downloaded and/or you can't open the book, then leave your iPad connected to the computer for a little while longer and hopefully it will fix itself after not-too-long.
  6. csipaduser macrumors newbie

    Jan 29, 2012
    fixed can't download issue for myself anyway

    Had the same problems. Wife suggested I had too little memory on iPad so I deleted a couple of videos which gave me 3 gb. First I had deleted the book as mentioned before and turned the iPad off then on, deleted the video and went back to the store downloaded in less than 10 min, give cool text book
  7. clickme6144 macrumors newbie

    Mar 14, 2012
    Same problem

    I couldn't download the book too, I have played any kind of tricks and films on it. nothing.

Share This Page