Some FN keys do not respond

Discussion in 'Mac OS X Lion (10.7)' started by erdeminanc, Feb 2, 2012.

  1. erdeminanc macrumors newbie

    Joined:
    Feb 2, 2012
    #1
    Hi everyone,

    I recently use an iMac Late 2009. I accidentally installed Developer version of 10.7.2 Mac OS X Lion, considering it is the official one. After giving it a look on the net, I found a way to go back to 10.7.1. After that I installed the official one. No problem till here.

    The keyboard issue began after that. F1,F2,F3,F4,F5,F6,F7,F8 and F9 do not respond. I checked it using virtual keyboard on MAC and I can't click on these buttons on the virtual keyboard as well.

    Yesterday, I upgraded my iMAC to 10.7.3, but nothing changed.

    So any suggestions for the issue?
     
  2. Ddyracer macrumors 68000

    Ddyracer

    Joined:
    Nov 24, 2009
    #2

    Do you have the below SS on standard function keys (check the box)? if not, turn it on, and it is a standard f12 keyboard.

    If that doesn't work try replugging your keyboard in.
     

    Attached Files:

  3. erdeminanc thread starter macrumors newbie

    Joined:
    Feb 2, 2012
    #3
    No, it is not checked. F10,F11 and F12 are working properly.

    Here is the SS of screen brightness settings. Computer thinks that there is F14 and F15, but I can never change it. FN keys from F1 to F9 do not respond.
    [​IMG]

    Uploaded with ImageShack.us
     
  4. Mal macrumors 603

    Mal

    Joined:
    Jan 6, 2002
    Location:
    Orlando
    #4
    Are you using an extended keyboard or the shorter keyboard? Either way, try this:

    Open System Preferences and click on Language & Text:
    [​IMG]

    Select Input Sources, then scroll down until you see the choice between U.S. and U.S. Extended. If you have an extended keyboard, make sure you're on the extended choice (I'm guessing maybe it's the opposite).
    [​IMG]

    jW
     
  5. erdeminanc thread starter macrumors newbie

    Joined:
    Feb 2, 2012
    #5
    Thank you for your help. I use a Turkish Keyboard, shorter one. It is the original iMAC keyboard. Tried all the possible combinations, but not solved yet :(
     

Share This Page