Some general Lion questions/issues

Discussion in 'Mac OS X Lion (10.7)' started by aManDismayed, Dec 23, 2011.

  1. aManDismayed, Dec 23, 2011
    Last edited: Dec 23, 2011

    aManDismayed macrumors newbie

    Dec 23, 2011
    So I finally made the switch from Leopard to Lion today after a few years (Skipped SL). I must say, while it's great to finally have a lightning-fast computer again, Lion really is a giant pain in the neck just as I suspected. I've spent now close to three hours and a few bucks on 3rd part software just to get it to run in a similar fashion to my darling Leopard machine. Finding something to simulate the all window exposé was annoying as hell (finally settled on Witch, which is nice admittedly).

    So the few questions I have remaining are these:

    1. All windows in Lion seem to open like they're spring-loaded or something, which annoys me quite a bit - is it possible to change this somewhere?

    2. I tend to use keyboard shortcuts as much as possible. An unfortunate side-effect of this is that I sometimes hit the wrong buttons, notably apple-Q instead of apple-W. Safari used to be pretty forgiving when this happened, splashing a warning when I attempted to quit a window with multiple tabs in it or quit while multiple windows were open. This doesn't seem to exist in Lion - is there a way to get this warning back, or do I have to struggle on without it?

    3. The downloads page seems to have been removed in favor of that little button thingy on the right of the browser window. Is this the case? If so, is there any way to separate the downloads function from the browser window so that I can just check that page if I minimize or close the browser windows?

    4. Scrolling - I really despise the way Apple is going with scrolling, changing it up to be more like the iOS. I've managed to change most of the settings back to a way that resembles Leopard for the most part but one thing still bugs me: when I scroll to the end of a page in Safari (and possibly other apps that I haven't explored yet), instead of stopping, it goes on past the end of the page and displays a nether-background of grey. What in god's name is the point of this? There's nothing there, trackpad, stop scrolling when you hit the end! So yes. Any way to disable this feature?

    5. Lion doesn't like long folder names, apparently. Is there any way to make it stop truncating the names no matter how long they are?

    Thanks in advance for any help whatsoever on these questions.
  2. satcomer macrumors 603


    Feb 19, 2008
    The Finger Lakes Region
    1. Click on the desktop then click on the menu item 'Finder' and choose 'Preferences'. You can turn it off or change the behavior.

    2. Adjust any keyboard shortcut in System Preferences->Keyboard and the mini tab 'Keyboard Shortcuts'. Also bookmark the page Mac OS X keyboard shortcuts.

    3. I haven't found a hack to change this part yet.

    4. That's strange.

    5. Click on the desktop again and select the menu option 'View'. Then in drop-down select 'Show View Options' and use the slider to change to the size that will show the long name.
  3. aManDismayed thread starter macrumors newbie

    Dec 23, 2011
    Thanks very much, though I'm still confused about 2 and 5. I'm looking to re-enable the warning dialogue when I quit safari and changing the size of the icons actually kept their names the exact same, interestingly enough.
  4. 0000757, Dec 24, 2011
    Last edited: Dec 24, 2011

    0000757 macrumors 68040

    Dec 16, 2011
    2, 3 and 4 are just how Safari works. It's not Lion that causes it, it's the version of Safari. It's the same on the Windows version. Simply go get Google Chrome or something else and you won't have that problem.
  5. aManDismayed thread starter macrumors newbie

    Dec 23, 2011
  6. Simplicated macrumors 65816


    Sep 20, 2008
    Waterloo, Ontario, Canada
    2. If Resume is turned on Safari will restore the windows when you relaunch it. That's why Apple did away with the warning dialogs.

    4. Go to System Preferences -> Universal Access -> Mouse & Trackpad -> Mouse Options, and select "without inertia" in the Scrolling field.
  7. 0000757 macrumors 68040

    Dec 16, 2011
    To be honest, Safari is awful. I really only use it because it flows with the gestures. I'm looking at other web browsers until I can find one that works as fluidly with the multitouch gestures. So far chrome works the best. Firefox was junky on them, but it doesn't do the over scrolling thing that Chrome and Safari use. I'm about to try Opera and see how it works out.
  8. aManDismayed thread starter macrumors newbie

    Dec 23, 2011
    This is all well and good if you're reading a blog or something, but if I'm watching a video or playing a game or something like that, it's still rather inconvenient. I'm surprised Apple didn't think of this.

    I have this turned off already, it doesn't solve the over-scrolling.

    As for browsers, honestly I've never really had as many issues with Safari as a lot of people claim to have. I do think Safari 4 was much more stable and am going to try to figure out how to downgrade sometime in the next few days, but on the whole I enjoy it a lot.

Share This Page