Some hard drives won't mount (this is a weird one)

Discussion in 'MacBook Pro' started by thefed, Nov 20, 2011.

  1. thefed, Nov 20, 2011
    Last edited: Nov 20, 2011

    thefed macrumors newbie

    Joined:
    May 5, 2011
    #1
    I have a 2011 Macbook Pro 15 inch, 8GB RAM, with self-installed SSD and HDD inside, running Snow Leopard. It has worked like a charm since day one. It's been nothing but great.

    Yesterday, one of my LaCie Rugged 500GB external hard drives wouldn't mount. Just didn't show on the desktop. So I tried my OTHER LaCie Rugged 500GB (same type) external hard drive, and it wouldn't mount either. So I plugged in an older Seagate hard drive, and that mounted just fine.

    So I checked on my Mac Pro (latest version, 24 GB RAM, 2TB internal hard drive from apple, running LION) that I have at work, and all those drives mount just fine on that one.

    So it seems that my LaCie hard drives are fine (i.e. not failing?), but just will not mount on my Macbook Pro. I've been using these for months with no problems. So what could be the problem now??? I've looked at many similar posts, but my problem seems different. The hard drives don't seem to be failing because they work just fine on my other mac. But on my laptop only these two have stopped mounting...and at the same time (same date). One idea: recently there was an Macbook Pro EFI update...could that have caused the incompatibility? Anyway, I'm baffled, and if you are so kind to have read this far AND can offer some help or advice, I thank you in advance.

    Additional info for those kind enough to have read this far: The LaCie Drives each have three partitions: Mac OS Extended Journaled (234 GB), NTFS (234 GB), FAT32 (32 GB). The Seagate is 1 TB of FAT 32 (I know, you're not supposed to do that, but I didn't know what I was doing when I formatted it, and amazingly to me, it works just fine!) None of the partitions on any of the hard drives mentioned are even half-way full (including my internals). They don't mount on my desktop, and they don't show up anywhere else on the Finder (but everything else does). Disk Utility does not see them.

    EDIT: forgot to add, I do hear the hard drives spin when I connect them to my Macbook Pro. Spinning sound is regular, steady, like normal.
     
  2. Heebeejeebies macrumors regular

    Heebeejeebies

    Joined:
    Nov 9, 2011
    Location:
    New Jersey
    #2
    A weird question, with weird advice: Check the wires?

    I had a problem with one of my externals which would mount on everything but my MBP, turned out it didn't fit right in my USB ports? It was very odd, but the problem was gone as soon as I got a new USB cable...

    You could try using the cable from the drive that does mount?

    :confused:
     
  3. Steve's Barber macrumors 6502a

    Joined:
    Jul 5, 2011
    #3
    Have you tried a different cable? When you took the LACIE to work did you also take the same cable used at home where the drives didn't work?

    Firmware screwup somewhere? Can you boot from an external drive with Lion installed, then hook up one of the LACIES to see if it mounts?

    Sorry dude, just grabbing at straws here.

    Edit: HeeBee beat me to the cable suggestion.
     
  4. dylan.shenton macrumors newbie

    Joined:
    Oct 22, 2011
    Location:
    England
    #4
    Maybe try booting into the recovery mode (Holding option on reboot and selecting 'Recovery') and then see if first that disk utility will recognise the disks, and then repair them?
     
  5. thefed thread starter macrumors newbie

    Joined:
    May 5, 2011
    #5
    I will try it!

    Thanks for the ideas, guys. Can't be the cables because they do work on my Mac Pro but not on my MBP. (I forgot to specify, the LACIE cables are USB 3.0!!! :eek: :eek:) Also, each drive has its own cable--it would be unlikely if BOTH cables went bad together. Can't be the USB ports on my MBP either--they work fine with other USB paraphernalia.

    I have not tried the recovery mode option yet. That will be the next thing I try, thanks for the suggestion.

    Back to the cables discussion, any idea if USB 3.0 and MPB/SL have suddenly become incompatible with the latest firmware/software updates??

    Thanks again for the help.
     
  6. thefed thread starter macrumors newbie

    Joined:
    May 5, 2011
    #6
    Update: I tried even a THIRD LaCie USB 3.0 external drive and same problem.

    Also, and what the hell, if I boot into Windows 7 using bootcamp, all hardrives are detected, just fine. Only OSX Snow Leopard does not detect them. And only recently.
     
  7. calderone macrumors 68040

    calderone

    Joined:
    Aug 28, 2009
    Location:
    Seattle
    #7
    Check System Profiler to see if the device is detected there.
     
  8. dionysious macrumors newbie

    Joined:
    Nov 19, 2011
    #8
    You know, sometimes in situations where there is no support or anything for your problem, try reinstalling mac osx. I had the kernel_task using 500mb always 24-7 and no one else was coping it, just me. installed lion again and boom, its gone.
     
  9. McGiord macrumors 601

    McGiord

    Joined:
    Oct 5, 2003
    Location:
    Dark Castle
    #9
    I am having a similar issue with an external HDD and a later 2008 MBP.
    The HDD can be connected via FireWire 800, 400 and USB.
    The Mac is running Lion 10.7.2.
    The HDD was working fine, but now it doesn't mount when using the FireWire port of the MBP. Only when using the USB port it is mounting.

    I will try with Snow Leopard to see what is happening.

    Unfortunately it seems to be a common issue:
    https://discussions.apple.com/thread/3199793?start=0&tstart=0

    Have you got yours to work?
     
  10. ruskat macrumors newbie

    Joined:
    Mar 22, 2012
    #10
    Lacie not mounting

    I have a 1TB Lacie External drive and I'm working on an OLD iBook G4 . The Lacie was working fine and then one day it just wouldn't mount on the desktop although the blue light was flashing as per usual and drive was making all the right sounds. The last time it worked properly, I had executed the full backup proceedure. As I had downloaded numerous add-ons and things since the last use, I can't rule out that any of them may have caused the issue..HOWEVER, I have found a way round it that works with mine. Hopefully it will also work for some if not all of you.
    Even though its not showing mounted anywhere else, I discovered that I could still get it to do a backup through the dashboard, at first I thought it wasn't working as the progress bar was moving but grey without any wording underneath it. I left it running and after about 15mins I was passing the comp and it was backing up files!! Guess what?! There was the Lacie mounted on the desktop. After it had finished the process I double-clicked the icon and it appeared to be working as usual, all files including new ones seem to be there and accessible. Only issue I have now is that when I try to eject/disengage the drive it says that applications are still in use when in fact they have already been quit. Must remark that each time this has happened I have used iPhoto. I welcome any questions but need to add that I am not a 'Tech-head', just a plodder.
     
  11. Dangerous Theory macrumors 68000

    Joined:
    Jul 28, 2011
    Location:
    UK
  12. towsen macrumors newbie

    Joined:
    May 14, 2012
    #12
    I have similar problem -- but even weirder

    My Mercury Elite USB terra drive has stopped mounting on my MacBook Pro

    BUT

    a thumb drive I put into one of the terra drive's extra ports does mount on my desktop.

    NOT ONLY THAT,

    but the USB drive does mount on my girlfriend's MacBook Pro.

    AND

    I'm not having problems with any other USB or Firewire devices.

    It used to work fine, then started getting temperamental about mounting, now nothing at all.

    I have tried switching to the root directory to see if it shows up there and somehow the permissions got screwed up, but I don't even see it there.

    Any help much appreciated!!

    John Towsen
    New York
     
  13. Curious George macrumors newbie

    Joined:
    Jul 24, 2002

Share This Page