Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

chroniceater

macrumors newbie
Original poster
Dec 31, 2012
5
0
Hi, I'm a new Mac user. My MBA runs Mountain Lion 10.8.2. Then I realised that some icons on my Desktop Menu Bar, Safari Menu Bar and Finder Menu Bar are missing. Here are some snapshots:

Desktop Menu Bar:
ScreenShot2013-01-11at191808_zps46715f8b.png

Safari Menu Bar:
ScreenShot2013-01-11at192841_zps846843ac.png

Finder Menu Bar:
ScreenShot2013-01-11at191831_zps82710d51.png


I need help to fix this. I've been looking for the solution for days but up till now I still couldn't find any. Please help me :( THANKS :D
 
Last edited by a moderator:

CrickettGrrrl

macrumors 6502a
Feb 10, 2012
985
274
B'more or Less
Hey thanks for your reply! But how can I do that? Sorry I'm a newbie on mac things :(

Open Applications/Utilities/Disk Utility (or Command+Spacebar, begin typing Disk Utility & click Return)

Select your hard drive and then:
 

Attachments

  • Screen shot 2013-01-12 at 11.22.54 AM.JPG
    Screen shot 2013-01-12 at 11.22.54 AM.JPG
    124.1 KB · Views: 909

CrickettGrrrl

macrumors 6502a
Feb 10, 2012
985
274
B'more or Less
Hey thanks! I did it but nothing changed

I looked on Apple's Support Community and this was occurring to numerous people back in November 2012.
http://discussions.apple.com/thread/4498102?start=0&tstart=0

One poster discovered that booting into Safe Mode corrected things, this was confirmed by several others.

RomanTS: "have good news. Few minutes ago I tried to login in safe mode in mac os x (simply press Shift during booting) and when mac was booted in "Safe mode" I logged in my account and after rebooted to normal boot. This fixed issues."

I'd give this a shot. Good luck, if it works, please let us know. :)
 

chroniceater

macrumors newbie
Original poster
Dec 31, 2012
5
0

octothorpe8

macrumors 6502
Feb 27, 2014
424
0
I hate to resurrect an old thread, but this just happened to me too (missing icons from Finder and Safari) and Safe Boot seems to have fixed it. Running Yosemite 10.10.1
 

mcneale

macrumors newbie
Aug 10, 2011
8
0
Richmond, Virginia
I hate to resurrect an old thread, but this just happened to me too (missing icons from Finder and Safari) and Safe Boot seems to have fixed it. Running Yosemite 10.10.1

Had the same issue with Yosemite 10.10.5 and the Safe Mode fix worked for me too. Safe mode login seemed to freeze, but it just needed about 10 minutes patience before it unstuck itself. My guess is that it was fsck'ing the disk at that time.

Has the core problem been fixed in El Cap - any occurrences under that OS? Seems to have been an ugly OS glitch for years...
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.