Some images don't load in Safari

Discussion in 'Mac Basics and Help' started by jive turkey, Mar 23, 2008.

  1. jive turkey macrumors 6502

    Joined:
    Mar 15, 2008
    #1
    I have been using my new Mac for 5 days, and I am confused about Safari. I have installed all of the necessary players (like Flash) I think. But when I go to http://www.redskins.com, the images in the top story and photo gallery panels do not load. The texts below them are there, but the images themselves are replace by a large black rectangular box that stretches into the video player just to the right.

    The top story & photo gallery images work well in FireFox (but the video doesn't work at all, oddly enough) so I don't think it is a website problem.

    Can someone tell me what setting I have fouled up or what content player I forgot to install?

    By the way, thanks for this forum. I have used the guides to solve many issues in these past 5 days. I am glad to be in the world of Mac.
     
  2. Ugg macrumors 68000

    Ugg

    Joined:
    Apr 7, 2003
    Location:
    Penryn
    #2
    I get the same thing with Safari. It's not a very well put together website.

    You might try emptying Safari's cache.
     
  3. richard.mac macrumors 603

    richard.mac

    Joined:
    Feb 2, 2007
    Location:
    51.50024, -0.12662
    #3
    the image gallery doesnt work in Safari for me either. i dont think the developers of redskins.com had Safari or WebKit for that matter in mind. works fine in Firefox.
     

Share This Page