(some) iPhone apps stuck at launch

Discussion in 'iPhone Tips, Help and Troubleshooting' started by lentife, Dec 23, 2008.

  1. lentife macrumors member

    lentife

    Joined:
    Dec 27, 2007
    Location:
    Rome, Italy
    #1
    Hi there!
    On my iPhone 3G, the apps "Brothers in arms" and "Ferrari Challenge" don't work, because when I launch them, the first game screen appars and then nothing happens. In Ferrari Challenge the screen turns completely white and nothing happens, and in BIA, the screen turns black.
    I have no idea what causes this!!! The app does not crash or freeze, because when I hit the home button I return to the springboard as normal...
    Are you experiencing something similar?
    Thank you!! Bye
     
  2. jmccullough108 macrumors 6502a

    jmccullough108

    Joined:
    Nov 2, 2008
    Location:
    St. Louis, MO
    #2
    Have you tried restarting the phone? That usually fixes it. If not, just restore your phone, since you already purchased the apps, you can just re-sync them.
     
  3. neesh0 macrumors 6502a

    neesh0

    Joined:
    Sep 6, 2008
    Location:
    Toronto, Ontario
    #3
    +1 for jmccullough108's answer, its important you restart your iphone after downloading a fairly big app from the app store.
     
  4. lentife thread starter macrumors member

    lentife

    Joined:
    Dec 27, 2007
    Location:
    Rome, Italy
    #4
    nothing worked... i re-purchased and i restarted after syncing before starting the app... :(
     
  5. jenzo macrumors member

    Joined:
    Nov 23, 2008
    #5
    if you check some of the appstore reviews brothers in arms isnt compatible with 2.2 firmware. looks like most if not all of the people who purchased it are upset and cannot play. however i have ferrari on my phone and it works fine so not the same issue there.

    ~jenzo
     

Share This Page