Some iTunes movies will not AirPlay without an internet connection

Discussion in 'Apple TV and Home Theater' started by Matt T, Jan 19, 2019.

  1. Matt T macrumors regular

    Matt T

    Joined:
    Dec 1, 2005
    Location:
    Australia
    #1
    I have moved into a new house and won’t have an internet connection for a few weeks, so I have downloaded a bunch of movies I purchased on iTunes to my iPhone and iPad. My plan is/was to AirPlay them to my Apple TV while I wait to get connected.

    Tonight I tried to play one of these movies and it wouldn’t work. I would briefly see the “this video is playing on your Apple TV” screen on my iPhone before that would disappear and nothing would play. Long story short, I spent a solid hour trying to figure out what was wrong and I’ve finally realised only *some* of the movies I downloaded won’t let me AirPlay them.

    Is anybody aware of why this would be? Do some movie studios not allow their movies to be AirPlayed?

    The movies which I can AirPlay:
    • Alien, Aliens, Alien 3, Prometheus, Alien: Covenant, The X-Files movie (20th Century Fox)
    • The Wolf of Wall Street (Paramount)
    Movies which I cannot AirPlay:
    • Jurassic Park: The Lost World, Jurassic Park 3 (Universal)
    • Harry Potter and the Deathly Hallows Pt. 1, Batman Begins, The Dark Knight, The Dark Knight Rises (Warner Bros.)
     
  2. waw74 macrumors 68030

    Joined:
    May 27, 2008
    #2
    not sure if it will help or not
    in the main airplay settings there's "play purchases from iCloud"
    try turning that off.

    It might be trying to grab those movies from the apples servers.
     
  3. Matt T thread starter macrumors regular

    Matt T

    Joined:
    Dec 1, 2005
    Location:
    Australia
    #3
    Thanks but this setting is already off. I toggled it on and off again, but that didn’t help.

    Yep, it seems that’s exactly what it’s doing. I connected the Apple TV to my iPad’s hotspot connection so it had internet access and then tried AirPlaying a Warner Bros movie from my iPhone, and it played at very low resolution - confirming that, even with the “play purchases from iCloud” setting disabled, the movie was actually streaming over 3G instead of AirPlaying locally. Very annoying and disappointing - I’ve emailed Apple Support asking for an explanation.
     
  4. Mr. Zarniwoop macrumors demi-god

    Mr. Zarniwoop

    Joined:
    Jun 9, 2005
    #4
    I have had similar experiences on airplanes non-AirPlay. The fix there is to go into Airplane Mode but turn on Wi-fi and Bluetooth.

    It’s almost like Airplane Mode tells the iOS apps “hey stop requiring an Internet connection back to Apple for DRM.”
     
  5. Matt T, Jan 20, 2019
    Last edited: Feb 14, 2019

    Matt T thread starter macrumors regular

    Matt T

    Joined:
    Dec 1, 2005
    Location:
    Australia
    #5
    Interesting... I'll try this tonight.

    Edit: for the record, this did not work.
     

Share This Page