(Some) Mail notifications not working

Discussion in 'iOS 12' started by Brian Y, Jan 2, 2019.

  1. Brian Y macrumors 68040

    Joined:
    Oct 21, 2012
    #1
    Hello!

    I'm having a weird issue which has started with the latest iOS 12 update.

    I have 3 email accounts - iCloud, Exchange and an IMAP one. For iCloud, notifications work fine. For Exchange and IMAP, no notifications are sent. I get the ding, and the app icon is badged - but there's no visual notification (for emails in the inbox).

    I've checked and all notifications are enabled - and I've also tried "reset all settings" but it's still not working.

    Any ideas?
     
  2. threeonthetree macrumors newbie

    Joined:
    Oct 21, 2018
    #2
    I also experience the same, I don't know what else to do to fix it
     
  3. PlayMoneyPro macrumors newbie

    Joined:
    Nov 9, 2017
    Location:
    Northern CA
    #3
    Just came here to post the same thing and I saw this thread. I wish Apple would address this. My wife has the exact same Exchange email (different address obviously) and she gets the notifications. She is on an iPhone X just like I am.

    So annoying!
     
  4. ATC macrumors 65816

    Joined:
    Apr 25, 2008
    Location:
    Canada
    #4
    It's annoying but there are a number of Mail notification bugs at the moment. One that I'm really frustrated by is opening new emails from lock screen Mail notifications, where it just opens Mail app to its last state (i.e. Inbox, or an already read email that was last opened) instead of the new unread email. This is happening with my iCloud email account. I filed a bug report through my Dev account last night. Hopefully Apple gets around to fixing these before iOS 13.
     
  5. Bhuntington macrumors newbie

    Joined:
    Jan 11, 2019
    #5
    I was having this issue as well (that's how I found this post). Not sure if it will work for you but mine was being caused by having my exchange inbox somehow set as a top level/favorite (not something I did, not sure if that was iOS12 or my work's Exchange server being changed). So when I go into mail the list of top level accounts WAS All, Personal, Work, VIP, Work Inbox. I removed Work Inbox (it's redundant since clicking on the work email ALSO sends you to the inbox) and the notifications started working again. If you go into Settings- Notifications- Mail, see if there's a "Favorite Mailboxes" option there in addition to your email servers. I had that and the notifications were set to off, conflicting with the regular folders. When I removed my Work Inbox as a favorite, it started working again. I guess they were conflicting. You could probably also update the Favorite Mailboxes settings and have them work as well. Again, this worked for me, not sure if it's the same issue though.
     

Share This Page