Some Photos ALL BLACK? iPhone 4

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Fazzl, Jun 24, 2010.

  1. Fazzl macrumors 6502a

    Fazzl

    Joined:
    Aug 13, 2007
    #1
    Ever since i had iOS 4 on my 3GS and now i am using my iPhone 4, i have like random pics in my camera roll that are just solid black. I think it happens when i delete a pic or at least thats when i notice it. Anyone else having this problem?
     
  2. roland.g macrumors 603

    roland.g

    Joined:
    Apr 11, 2005
    Location:
    One mile up and soaring
  3. Snowman3459 macrumors 6502a

    Joined:
    Jun 15, 2010
    #3
    I had this issue but if you actually click on the picture it will show up.
     
  4. Blueline29 macrumors 68020

    Blueline29

    Joined:
    Jun 16, 2009
    Location:
    Windermere, FL
    #4
    I have this issue, too...it doesn't seem to be directly correlatable to deleted pics (though some places where the deleted pics would have been are showing up as black); the black often shows up almost like a placeholder for pics that haven't been deleted. Annoying bug.
     
  5. Fazzl thread starter macrumors 6502a

    Fazzl

    Joined:
    Aug 13, 2007
    #5
    hmm this is getting very annoying. i just took like 3 videos and i can't watch them cause they are just a plack image. i don't know what i do. I figure i can wipe and do a clean install as a new phne but ill loose all my folders and itl take like an hour to redo.
     
  6. wackulous macrumors member

    Joined:
    Jun 21, 2010
    #6
    i had the same issue, i backed out to the camera roll, went back into it, and now it works...for now
     
  7. M-5 macrumors 65816

    M-5

    Joined:
    Jan 4, 2008
    #7
    Yeah I've had this same issue with deleted pictures. It's also occurred from albums that I've imported to the iPhone from my Mac and then removed; I'll just see black spaces. It's a weird bug.
     
  8. doc xavier macrumors newbie

    Joined:
    Aug 17, 2010
    #8
    this also happened to me yesterday when i deleted the last photo from my iphone album. the 10-15 pictures before it suddenly turned black in camera roll. meanwhile, the rest are visible (>500 pics). i shifted back and forth to camera roll-albums-view, turned the iphone on and off, took another pic, deleted another, but nothing restored the photos. like the others who posted here, when i selected the blackened:confused: photos, you can view them individually. yes, this was after i updated to 4.0.2. clearly a programming bug :mad:
     
  9. saving107 macrumors 603

    saving107

    Joined:
    Oct 14, 2007
    Location:
    San Jose, Ca
    #9
    Exit out of the Photos app, double click the Home button for multitasking, kill the photos app, then relaunch it.

    This has something to do with Multitasking being enabled, my iPhone 4 and 3GS running iOS 4.0.2 have this issue, but not my 3G on the same OS.
     
  10. Small White Car macrumors G4

    Small White Car

    Joined:
    Aug 29, 2006
    Location:
    Washington DC
    #10
    Nope. I've had this issue since I bought my i4. It happens on probably 3-4% of my photos. Nothing I've tried fixes it.

    Nope. It shows a tiny, tiny thumbnail blown way up. It's very pixelated. Clearly the actual photo isn't in there at all.

    See below. One of those is a photo that was properly synced. The other is what happens when I touch a black square. It opens that blurry photo since that's all it has saved, apparently.
     

    Attached Files:

  11. ARF900 macrumors 65816

    ARF900

    Joined:
    Oct 30, 2009
    #11
    Are all of you running 4.0.2?

    did you experience this problem before 4.0.2?
     
  12. Small White Car macrumors G4

    Small White Car

    Joined:
    Aug 29, 2006
    Location:
    Washington DC
    #12
    On the original 4.0 and on 4.0.1.

    None of the updates thus far have changed anything other than the signal bars and that website jailbreak exploit. I doubt anything will change until 4.1.
     
  13. MotleyGrrl macrumors 6502

    MotleyGrrl

    Joined:
    Jun 15, 2010
    Location:
    Chicago, IL
    #13
    I had this issue shortly after I got my ip4 in June. It bugged me for a while but I got used to it. Then a few weeks ago I went to open my camera roll and got an updating photos message - then my camera roll was back to normal. Nothing I did fixed it, it just randomly fixed itself.
     
  14. tnsltwn macrumors 6502

    tnsltwn

    Joined:
    Aug 2, 2010
    #14
    It should be fixed in the next iOS4 update. If it happens restart your phone. I was having problems with text messages not showing and did a clean reinstall and it fixed that. It sucks but until the next update it's the only way.
     
  15. alFR macrumors 68020

    Joined:
    Aug 10, 2006
    #15
    Might be useful if one of you reported this as a bug to Apple to make sure it gets fixed (unless you've done that already, of course).
     
  16. Benito macrumors 6502

    Benito

    Joined:
    Jan 5, 2010
    Location:
    Toronto, Canada
    #16
    I've had this happen on my 3G on 4.0.2. Exiting out and then going back into the camera roll didn't help.
     
  17. fuzion11 macrumors 65816

    fuzion11

    Joined:
    Sep 24, 2008
    Location:
    Hamilton, Ontario
    #17
    I too had this problem, but only with videos I've taken in the past with my 3GS....Not the videos I've taken with the iP4.

    I tired erasing them and resyncing them back to the phone just to have the same problem continue.

    Not sure what the issue is...but I think it may be because those videos were shot with a 3GS 3MP and now with the 5MP...could that be it?
     
  18. wskidmore macrumors newbie

    Joined:
    Aug 25, 2010
    #18
    Same problem

    iPhone 3G, running 4.0.2, probably about twenty pictures are just a nice, big black blob...
     
  19. cecec macrumors newbie

    Joined:
    Aug 27, 2010
    #19
    3G with 4.0.2

    i have a 3G, and when I updated with the 4.0.2 software, thats when the pictures were black. once i click on the pictures, I can see them clearly. Its probably 30 or so pictures. I tried to plug it into the computer and sync the pics again but itunes says it "will not support putting photos on this iphone" or something along those lines. I think all these pics are ones that i actually took on the phone, so why arent they showing up? Arent the new softwares supposed to help the phone not handicap it?
     
  20. celinabean macrumors newbie

    Joined:
    Oct 15, 2010
    #20

    any luck with the blob of black photos??? i just updated on my 3g yesterday to find about 50 pictures all black.. i have some from when i first go the phone, and recent ones.. but anything in the middle is just a big black chunk...
     
  21. jessicamd macrumors newbie

    Joined:
    Oct 16, 2010
    #21
    I fixed mine...

    Guys, I have actually fixed it! I have a mac, and so I plugged it in and opened iPhoto. I synced all of the photos to the computer and then deleted them all. I re-synced them via iTunes and they show up! I was keeping this as a last resort. I tryed taking a few photos and they show up too!! :)

    Before hand I had just updated my phone to 4.1 .
    Happy, I explored my phone to see what it had changed, and I had a big continuous black rectangle over the tumbnails of my photos and i could press them and the photo that was meant to be here showed up :confused: . Confused I went onto Apple and posted this as a problem, but as i did so i had this idea ^^ so i did it and i worked :) .
    I really hope I helped you guys!
    :D :apple:
     

Share This Page