Some Serious Start Up Troubles...

Discussion in 'Mac Basics and Help' started by unefaux, May 27, 2013.

  1. unefaux macrumors newbie

    Joined:
    May 27, 2013
    Location:
    Cincinnati, OH
    #1
    Hi! I hope I'm posting this in the right forum. I'm not very experienced with the Mac OS; I've always been a Windows guy myself (sorry!), but I had to get a MacBook Pro for school when I switched majors last Fall.

    Also, I really apologize for the length of this post, but I'm kind of freaking out here. This computer was really, really expensive, and it's mandatory for my major, and has all of my work on it. Any help or comments are greatly appreciated!

    Here is some prerequisite information before I continue:
    -The computer involved is a MacBook Pro from June 2012 (not the newer Retina Display one) running OS X 10.8 Mountain Lion.
    -It has a 750GB HD, 16GB of RAM, and a 13.3" screen.
    -I bought the computer used.
    -I have never experienced any other problems remotely like this with the computer.
    WHAT WORKS:
    -Internet Recovery, Mac OS X Utilities
    WHAT DOESN'T WORK:
    -Everything else

    So last night, my computer froze. I could do nothing but switch between desktops (swiping to the left or right with three fingers), so I pressed the power button to force shut down. But, upon rebooting, I was greeted by a folder with a question mark, flashing on and off. After doing a bunch of stuff (resetting the PRAM, resetting the SMC, trying and failing to enter both single-user and safe modes, etc.), I finally got Internet Recovery to work (after multiple attempts and receiving multiple error codes, none of which have ANY support or even mention on Apple's site) and the computer to get to a place where I could access Mac OS X Utilities. Unfortunately, I have no Time Machine backups, nor do I have the reinstall disc (I bought it used), and the "Get Help Online" option yielded nothing. However, Disk Utility was readily available. The day was saved! Or so it seemed.

    When I click on Disk Utility, the only options on the left are "SuperDrive"--the CD drive, which is greyed out--and "disk0," with a dropdown category of "Mac OS X Base System." I have scourged the internet far and wide, and I can find absolutely nothing on what to do next, or what these directories even are. The Apple support site says to highlight my HD, go to the First Aid category, and click "Repair Disk;" however, my HD is not listed (unless it is, for some reason, going by the name of "disk0") and the "Repair Disk" option is greyed out, as are all the others.

    I have absolutely no idea what to do next. I have tried booting up in safe mode and single-user mode, but the computer is having none of that. I've reset the PRAM and the SMC. I've tried holding cmd+R, D, and R during bootup to no avail. The only thing that seems to work is holding opt down during startup to get to Internet Recovery. I seriously cannot fathom the possibility that the forced shut down I performed last night could have seriously damaged the physical HD. I may not be an expert on the Mac OS, but I do have some basic computer knowledge. I'm probably going to take it in to a Genius tomorrow (it's Labor Day today), but I'd really like to get this solved without them (my budget is almost non-existent). I'm also really, really hoping that a complete wipe of the HD is not necessary.

    Again, I really apologize for the length of this post! But I really want to be thorough so the problem can be solved and quickly and painlessly as possible. Thanks for reading!
     
  2. satcomer macrumors 603

    satcomer

    Joined:
    Feb 19, 2008
    Location:
    The Finger Lakes Region
  3. Fishrrman macrumors G3

    Joined:
    Feb 20, 2009
    #3
    Try this:

    Power the Mac down -- completely off.

    Press the power on button.

    As soon as you hear the startup sound, hold down the option key and KEEP HOLDING IT DOWN.

    In a few moments, you _should_ see the startup manager, which will display 2 icons:
    - One for your main partition (where all your stuff is)
    - One for the recovery partition
    (NOTE: if the internal drive has failed, you may not get this far)

    Use the pointer or tab key to select the recovery partition and hit return.

    Normally, you should next see the recovery partition screen, with several options, Disk Utility is among them.

    Can you get this far?
     
  4. Apple fanboy macrumors P6

    Apple fanboy

    Joined:
    Feb 21, 2012
    Location:
    Behind the Lens, UK
    #4
    Do you have an external Hard Drive? If so you could boot to that if you had a bootable copy of your internal HD. Carbon Copy Clone would have been the way to go. However if your hoping the Genius will be able to recover your HD if its damaged I think your going to be out of luck. Still worth going to see what they say.

    If it's less than 12 months old even without Applecare they should repair it under warranty. Good luck and remember to always have at least one back up in future.
     
  5. unefaux thread starter macrumors newbie

    Joined:
    May 27, 2013
    Location:
    Cincinnati, OH
    #5
    Kind of. When I get into Recovery mode, it doesn't show my HDD and the Recovery HDD. It just goes straight to Internet Recovery.

    ----------

    Unfortunately, no :( The only option for Startup Manager is Internet Recovery. Although I can get to Disk Utility. However, I'm not sure what to do in Disk Utility, because my HDD isn't listed in the left. The only options are "disk0," which has a dropdown category of "Mac OS X Base System."

    ----------

    I do have an external harddrive, though I don't believe I have a bootable copy of my internal one. I'm really hoping this isn't the case :( It would have been so sudden!
     
  6. Fishrrman macrumors G3

    Joined:
    Feb 20, 2009
    #6
    "Unfortunately, no The only option for Startup Manager is Internet Recovery. Although I can get to Disk Utility. However, I'm not sure what to do in Disk Utility, because my HDD isn't listed in the left. The only options are "disk0," which has a dropdown category of "Mac OS X Base System.""

    If you can't even get to the point where you can see the "presence" of your internal drive via the startup manager (as you have described above), it could be a couple of things:
    - hard drive (software corruption -- to the point where the Mac no longer sees the drive as being "bootable")
    or
    - hard drive (hardware failure - drive has mechanical problem)

    Is the computer under warranty?
    If so, take it to an Apple Store and get the drive replaced. They _may_ be able to recover your data files for you (if it was a software problem and not a hardware problem).

    Is the computer out-of-warranty?
    If so, then you're going to have to fix it yourself.

    I see you have been getting to the point of "internet recovery".
    What happens when you actually try to "recover"?
    Can you install a new copy of the OS onto the internal drive?

    One last thought:
    Others may disagree with me, but my advice is to ALWAYS keep a "cloned copy" of your itnernal drive available, just for situations like this.

    It's not hard to do this (even a troglodyte like me can do it!).
    Nor is it expensive. You just need a couple of pieces of hardware and the right software.

    If you absolutely "can't get anywhere" with the internal drive, then my next advice would be:
    1. Buy a USB3/SATA docking station ($30)
    2. Buy a new internal hard drive (preferably an SSD)
    3. Install a fresh copy of the OS onto the new SSD (while in the dock)
    4. Do a test boot to be sure it works
    5. Open up the MacBook and swap drives (MAKE SURE you have the properly-sized screwdrivers)
    6. Swap drives, get MacBook going again
    7. Now the dock can be used to "get at" the data that remains on the old drive.
     
  7. Eric Lee macrumors newbie

    Joined:
    May 24, 2013
    #7
    Hi,

    It might only be the SATA wiring and not a fully failed HDD. It is a very common problem with 2009 MacBook Pros and since they used nearly the same wiring in later models the known problems might carry on onto those. If it's only the SATA cable repair costs won't be high and you probably won't loose any data.

    Was one of these "multiple errors" a POSIX 12 (cannot allocate memory) error code?

    He already stated, that the OSX partition is not showing up in Disk Utility anymore (actually the disk0 is the internal HDD, but if it's not showing your old partitionmap then something failed), so either it is a bad HDD or a bad SATA cable or the controller failed (I'd doubt the latter because Intel controllers can take quite much and usually don't die from one second to another; also you wouldn't see disk0 with a dead controller). If Disk Utility won't recognize the drive there is no chance whatsoever, that Internet Recovery can do anything about that.
     
  8. Fishrrman macrumors G3

    Joined:
    Feb 20, 2009
    #8
    "If Disk Utility won't recognize the drive there is no chance whatsoever, that Internet Recovery can do anything about that."

    I was thinking that too.
    That's why included the advice that he
    - get a new drive
    - get a USB/SATA dock
    - do an "internet recovery" to the docked SSD drive
    - swap the new drive out for the old one
    - use the dock for an attempt to get at the data on the old drive (unlikely if it's had a hardware failure)
     
  9. johnquattro macrumors newbie

    Joined:
    Feb 17, 2016
    #9
    Did you ever resolve this issue? I'm having exactly the same issue and I just arrived in a country (Congo) with no Mac stores, so I'd really appreciate any insight you can give!
     
  10. Nimapatel macrumors newbie

    Joined:
    May 14, 2016
    #10
    I have the same problem. Flashing folder when I try to boot.

    I took the disk out & put it in a USB/SATA dock & connected it to an Ubuntu Linux PC. After looking at it with gparted, I found it would mount & I could see folders. I backed up my user folder using gsync. So the disk appears physically fine.

    Then, I tried plugging the USB/SATA dock into the Mac & used <cmd> R to start internet recovery. I could see my disk listed on the left as "untitled"!

    I ran Verify Disk which came up with an error. I ran Repair Disk and that fixed the error.

    I put the disk back in the Mac & it still would not boot: flashing folder again. Maybe this is a disk cable problem?

    I put it in the disk back in the USB/SATA dock & tried holding C down in order to "start up from a bootable" to try to boot the disk on USB. I got an apple symbol & a progress bar; this changed to a No Entry sign. No error messages.

    I tried <option><cmd>C The same thing happened. No error messages.

    I tried using internet recovery to re-install OS X. I got the message "You can't upgrade this version of OS X because a newer version is installed".

    I'm considering giving up on Mac OS X as it is so unhelpful. Life is too short for this.

    I might install Ubuntu & restore my backed-up files. But I need to get the MacBookPro to talk to the disk first.
     
  11. richard2, May 14, 2016
    Last edited: May 15, 2016

    richard2 macrumors regular

    richard2

    Joined:
    Oct 21, 2010
    Location:
    England, United Kingdom
    #11
    It's possible. Why haven't you already replaced the cable? o_O

    The prohibitory sign screen is presented when your Mac finds a system volume but fails to boot from it. In your case, your Mac is probably failing to boot because one or more system files are corrupted or missing.

    After you've replaced the disc drive cable, create a bootable OS X installation disc and then use it to attempt to reinstall OS X.

    Tip: Hold option when you power on your Mac to choose a boot volume.
     
  12. Nimapatel macrumors newbie

    Joined:
    May 14, 2016
    #12
    Richard2, thanks for this help, particularly about the prohibitory sign. After re-installing OSX I got it the disk to boot via USB. I carefully examined the disk cable under a magnifier. It looked undamaged. I replaced it & re-installed the disk inside the body, not on USB. It worked & booted up fine! So there was some mystery fault with the disk cable.

    Thanks again for your advice :)
     
  13. richard2 macrumors regular

    richard2

    Joined:
    Oct 21, 2010
    Location:
    England, United Kingdom
  14. Nimapatel macrumors newbie

    Joined:
    May 14, 2016
    #14
    Oh and for others reading, before OSX would boot successfully, I had to re-flash PRAM. This was not an obvious requirement, but it made all the difference.

    I've never had a disk cable fail before. Strange!
     

Share This Page