Some songs don't play in iPod touch

Discussion in 'iPod touch' started by filenew, Oct 3, 2007.

  1. filenew macrumors newbie

    Joined:
    Sep 28, 2007
    #1
    Does anyone have issues with some songs not playing with iPod touch? The iTune plays the music, seems to sync and the album cover shows up, but when I tried to play it on iPod, the track doesn't play and the progress bar doesn't move.

    Any idea on how to fix this? Thanks in advance.

    PS. I've tried deleting and resyncing, but having the same problem.
     
  2. ivi7 macrumors 6502a

    ivi7

    Joined:
    Sep 17, 2007
    #2
    The only think I can think of is retoring the touch maybe that will sort out the issues
     
  3. 03sho macrumors 6502a

    Joined:
    Sep 19, 2007
    Location:
    UK
    #3
    Are these songs form a cd, bought on itunes store or d/l from a site?
     
  4. sundayx macrumors member

    Joined:
    Sep 15, 2007
    Location:
    Hong Kong
    #4
    This also happens to me, on one particular album. It was downloaded not from iTunes.
     
  5. 03sho macrumors 6502a

    Joined:
    Sep 19, 2007
    Location:
    UK
    #5
    If it was downloaded from torrents etc then it could be corrupted.
    This happened to my 2nd gen nano and it froze until the battery ran out.
     
  6. filenew thread starter macrumors newbie

    Joined:
    Sep 28, 2007
    #6
    The songs were d/l, but other mp3 players don't have problem playing them. So it's weird that iPod can't play.

    Has anyone tried to convert the files to wav and reencode it mp3? (using lame or something).
     
  7. jnc macrumors 68020

    jnc

    Joined:
    Jan 7, 2007
    Location:
    Nunya, Business TX
    #7
    I had a song that skipped about halfway through playback today. Alarm bells! It plays fine on my Mac.. :(
     
  8. Cache macrumors regular

    Joined:
    Sep 12, 2007
    #8
    Had the same. Just one song atm that plays like 10 secs on the ipod then skips to the next song.
     
  9. SirithX macrumors 6502

    SirithX

    Joined:
    Feb 21, 2007
    Location:
    San Francisco
    #9
    I've had this problem too, I think it's some sort of bug. I didn't notice it before 1.1.1, but lately I've been finding songs that simply don't play on the Touch, it syncs just fine, the album art shows but it stays on 0:00 and doesn't play. Some songs will "play," as in the progress bar will move as if the song is playing, but no music will come out, and if you move the progress bar anywhere then it will finally start playing the music wherever you dropped it. And of course only the Touch has these problems, my Mac plays them fine in iTunes, my old iPod mini has played them fine for years, there's absolutely nothing wrong with the files, which are mp3s even. But if you have this problem, the only solution I've found so far is to just reconvert it using iTunes (to the same format, or something else if you wish) and then the new file will play like it's supposed to on the Touch.
     
  10. macnascent macrumors newbie

    Joined:
    Oct 4, 2007
    #10
    On my new 16GB iPod touch I'm suffering from this on some songs, too, and it's reproducible every time at the same location within the song. One of the songs in particular is a track I ripped via iTunes from a CD I own. The default encoding setting I have for iTunes is AAC so this is AAC-encoded. I read in a related thread on this site that someone mentioned when they converted the file to mp3 the problem went away. I haven't tried that yet. Of course, one could do that only with ripped tracks. Downloaded ones from iTunes are only AAC so that wouldn't be an option :(

    As a test I tapped the screen to display the progress bar while the offending track was playing. I found that if I drag the current position in the song to just past the point where it otherwise fails (i.e. stops), then the song will play to completion. Finally, I have tried resetting and clearing my iPod touch (a couple of times) and resync'ing everything, but that didn't cure the problem.

    I'm not sure what I'm gonna do. I'm pretty bummed about this. I would hazard a guess this could be fixed via a firmware update to the touch, but at $399 I spent for this thing, I don't know if I want to wait very long for that; well, especially beyond the return period I have.
     
  11. Afreelunch macrumors newbie

    Joined:
    Oct 31, 2009
    #11
    bump!

    I've been searching around and finally found a thread describing my exact problem. I have a 1st gen 16 gb iPod touch, and the condition described in the OP is happening to me too. All the songs that will not play are songs that I purchased from the itunes store, and there are more than a few entire albums that do this. Does anyone know how to fix this? I'm getting more and more fed up with apple products every time I try to give them a chance!
     
  12. brunobarros macrumors newbie

    Joined:
    Feb 23, 2012
    #12
    After a long time of inactive thread, I had the same problem today with my iPod Touch 2nd generation (iOS 5.0.1). I solved the problem erasing all the songs from my ipod and transferring to it again. I hope it help you.
     
  13. Eddy Munn macrumors 6502

    Eddy Munn

    Joined:
    Dec 27, 2008
    #13
    OP was last online on 4th October 2007, I don't think he will see this.
     

Share This Page