Some sound sources are not routed through selected output

Discussion in 'Digital Audio' started by uncleMonty, Sep 8, 2014.

  1. uncleMonty macrumors regular

    Joined:
    Jun 8, 2012
    #1
    Hi - I solved one problem I had earlier, but now I have another. I've installed the software synth ZynAddSubFX (and can control it via MIDI) but cannot get it to output the sound to my audio interface and external monitors, instead it insists on using the internal laptop speakers. The other sounds from the laptop are all correctly routed to the external audio interface (Apogee Duet 2). How is this even possible? Here's what I've done:

    In Jack Audio, I've connected the softsynth to the system audio.

    In audio preferences, I've set the output device to Duet USB.

    So how can the softsynth be coming out of the internal laptop speakers instead of through the interface?? As far as troubleshooting, the only things I know to check are the things I've mentioned already. Thank you for any guesses as to what I could do next.
     
  2. uncleMonty thread starter macrumors regular

    Joined:
    Jun 8, 2012
    #2
    Ok, it's solved. Solution, in case anyone comes across the thread in the future, was that Jack Pilot had an extra field I needed to configure in order to route audio from the softsynth properly.
     

Share This Page