Some webpages not loading in Lion

Discussion in 'Mac OS X Lion (10.7)' started by treehorn, Sep 10, 2011.

  1. treehorn macrumors 6502


    Aug 21, 2007
    Ever since upgrading to Lion, I have found a few websites that don't work - the introduction page loads slowly, and clicking on links within them to get to secondary pages results in a white blank screen.

    I know this is a Lion issue because it works on my computers running Snow Leopard and Leopard. The sites also load fine on iPad and IPhone.

    It's not a browser issue because it happens on Safari, Firefox and Chrome (the latter of which gives the following error message: Error 324 (net::ERR_EMPTY_RESPONSE): The server closed the connection without sending any data.)

    It's not a virusbarrier issue as I've disabled it completely to trouble shoot.

    I have tried turning off various things in Lion that could cause it (emptying all caches, resetting Safari, browsing in Private mode, turning off all firewall/security features...thus opening myself up to a potential world of hurt)

    Are there some sites that have code that aren't Lion compatible? Or is there a privacy/security setting in Lion I haven't come across?
  2. QuarterSwede macrumors G3


    Oct 1, 2005
    Colorado Springs, CO
  3. iBrody macrumors 6502

    Jun 11, 2008
    The macrumors homepage doesn't load via Safari on my 2011 MBP (Lion upgrade).

    I get a white screen.
  4. treehorn thread starter macrumors 6502


    Aug 21, 2007
    A big one today is, which pulls up fine on my iPad but on Safari, Chrome and Firefox on my computer running Lion...all I get is a blank screen

    This is the error I get in Chrome:

    No data received
    Unable to load the webpage because the server sent no data.
    Here are some suggestions:
    Reload this webpage later.
    Error 324 (net::ERR_EMPTY_RESPONSE): The server closed the connection without sending any data.

    Happens on a couple other sites rather consistently (ones that you need to be a member to even look at them so posting wouldn't help)
  5. squeakr macrumors 68000


    Apr 22, 2010
    I would suggest trying to clear out your keychain access. It sounds like something might have changed during/after the Lion upgrade and these identities within Keychain access are not letting the pages receive/send data (especially sounds like this as you said some of the pages you must be a member to display them and it is not browser dependent). I would say clean out/ delete your keys and then try to reach the sites and reestablish the keys with those sits. Good luck with this.
  6. treehorn thread starter macrumors 6502


    Aug 21, 2007
    I've done that - and cleared/reset all safari access. Sounds like a problem that has been cropping up on a lot of people's systems...or at least a lot of friends of mine are having problems
  7. iBrody macrumors 6502

    Jun 11, 2008
    Managed to solve my issue, it was the MacRumors web extension that I had installed for the browser (thought I had only downloaded it in Chrome but it must have carried across to Safari when I imported preferences, and it somehow glitched). Uninstalled it and all works fine.

    To original poster, if you have installed any web extensions for your browser, have you tried disabling them?
  8. treehorn thread starter macrumors 6502


    Aug 21, 2007
    No web extensions...and as it's a Firefox/Chrome/Safari problem...

    Did finally do a 'doh' 101 moment...checked the sites on my partner's laptop, which is running Lion (and he has a gazillion web extensions) and they all worked fine. In fact, sites loaded a lot faster on his laptop (even further away from the WIFI) than my computer does.

    Which is making me re-think it's Lion issue. But as I've reset safari, cleared all caches, cleared all preferences, etc..

    Wondering if it's due to something I was reading in MacWorld or MacLife about Snow Leopard remnants sometimes being left behind and how a $10 program cleared it right up...
  9. itsmeaf macrumors newbie

    Jun 21, 2011
    Check your DNS. If it has a then it may be the problem. Especially you start to be unable to get to sites like google etc.
  10. whohasaquestion macrumors 6502a

    Sep 17, 2011
    If that's the case, which DNS should we be using? Comcast customer here.

    Btw, do I change the DNS for the comcast wired router, the netgear wireless router and the MBA wireless adapter all together? Or changing one of these will suffice?
  11. treehorn thread starter macrumors 6502


    Aug 21, 2007
    Finally got things to work...not sure what the final solution was, but I suspect running Lion Cache Cleaner did the trick (between optimizing for Broadband, optimizing files, deleting fragments of some start-up items that weren't supposed to be there and getting rid of cache on a deeper level than Clean My Mac or anything else I tried...)

Share This Page