Some websites don't work on my Macbook, but they do on my iMac

Discussion in 'macOS' started by karenflower, May 12, 2008.

  1. karenflower macrumors 6502a

    karenflower

    Joined:
    Dec 7, 2007
    #1
    Hi, I have a problem with my internet and I have no idea what's causing it. :/

    My iMac is connected to the router via ethernet, and I wirelessly connect to the router from my Macbook.

    A while ago (few months), I stopped being able to connect to xkcd from my Macbook; it gives a 'network timed out' error. It's never worked since - I can only get there via a proxy, or on my iMac. I can't see any router settings that could have made this happen (I have a Zoom X6 if it's any help), nor can I find any settings in my Macbook's System Preferences.

    Recently, another website has begun to do the same thing - Victoria Health. It worked fine a couple of weeks ago, now it's only accessible on my iMac. I've tried clearing all browser caches, I reset Safari and tried different browsers but nothing seems to work.

    I'd be very grateful if anybody has any suggestions! Thanks.
     
  2. Amdahl macrumors 65816

    Joined:
    Jul 28, 2004
    #2
    Try upgrading the firmware on your wireless access point.
     
  3. karenflower thread starter macrumors 6502a

    karenflower

    Joined:
    Dec 7, 2007
    #3
    Thanks for the suggestion. I just tried connecting on my Macbook via ethernet instead of wireless and it worked fine! :confused: So I'll have a look and see if there's a firmware update to fix this. Maybe it's a bug perhaps?

    Edit: Just looked and I have the current version. I guess it's just something I'll have to live with? :p
     
  4. operator207 macrumors 6502

    Joined:
    Jul 24, 2007
    #4
    mtu mismatch on either the AP or your wifi setup, or the router you connect with down the line at your ISP or anywhere in between.

    Its unlikely, unless someone who did not know what they were doing started playing with stuff they have no business playing with (defaults are almost always just fine).

    Its something that could affect you.

    At one point at an ISP I worked for back in the 90's, we had one modem pool that would allow you to get to www.lycos.com (This was when you would see the "Lycos, go get it!" "arf, arf!" commercials) but via another modem pool, you could not. The fix was to change the MTU on the modem of the dial in user when this happened. Though if that user dialed into the other modem pool, they would have other issues.
     
  5. Amdahl macrumors 65816

    Joined:
    Jul 28, 2004
    #5
    As operator207 says, it is likely an MTU issue. The cause is likely a bug in your firmware, or a foolish firewall feature in the access point.

    You can test by running the following command in Terminal:

    sudo ifconfig en1 mtu 1400

    If the site works afterward, you very likely know the problem. If not, the setting goes away on reboot.
     

Share This Page