Somehow I have accidentally hidden my apps

dogbone

macrumors 68020
Original poster
I'm not sure how I did this I think I set an option somewhere but I can't find where. Only one window is visible at a time. It is like I have chosen "hide others" in the application switcher. As soon as I select an application all the previous one disappears so only the current one is visible.

I thought I did this by checking a box in OnyX as I was mucking around with that program but I have spent a couple of hours looking at it many times and everywhere else I can think of and I can't see how I did it.

Any suggestions?
 

yenko

macrumors 6502a
Aug 29, 2005
522
0
SouthWest-USA
dogbone said:
I'm not sure how I did this I think I set an option somewhere but I can't find where. Only one window is visible at a time. It is like I have chosen "hide others" in the application switcher. As soon as I select an application all the previous one disappears so only the current one is visible.

I thought I did this by checking a box in OnyX as I was mucking around with that program but I have spent a couple of hours looking at it many times and everywhere else I can think of and I can't see how I did it.

Any suggestions?
Finder>Preferences>General>check: Always open folders in new window.
:)
 

dogbone

macrumors 68020
Original poster
I have found where the problem is finally but not what caused it.

The problem is coming from X-Assist. But It's been fine ever since I have been running Tiger, (about a week) I recently downloaded a OnyX, and Quicksilver and a System Optimiser X and since then X-Assist has had this problem

So I suppose it is some kind of conflict. Which is a bit sad as X-Assist was so useful.

Maybe someone has some ideas why a program like this would suddenly play up.
 

dogbone

macrumors 68020
Original poster
It's all back to normal again. It was just a bit of weirdness with X-Assist.

I unchecked the (Toggle Windows Mode) in the drop down preference and restarted and it went back to normal. Even though it keeps defaulting to being checked! but even though it keeps defaulting to 'checked' it still works normally. I don't know what caused it in the first place. But my favourite app is working OK again. I don't think it will survive the next OS upgrade though.
 

yenko

macrumors 6502a
Aug 29, 2005
522
0
SouthWest-USA
dogbone said:
...................... I don't think it will survive the next OS upgrade though.
I think you're right! :eek:

The prudent thing to do is not to install "hacks". :eek:

When you update the OS and then wonder why your s*** don't work or freaky things happen...........oh oh, I'm on a rant.......... :eek:

Guess that's why we have these forums!! :D :D
 

Jacob Palme

macrumors newbie
Nov 19, 2016
1
0
I'm not sure how I did this I think I set an option somewhere but I can't find where. Only one window is visible at a time. It is like I have chosen "hide others" in the application switcher. As soon as I select an application all the previous one disappears so only the current one is visible.

I thought I did this by checking a box in OnyX as I was mucking around with that program but I have spent a couple of hours looking at it many times and everywhere else I can think of and I can't see how I did it.

Any suggestions?
This problem may be caused by use of the X-assist menu. If you check your menu bar, you will see that there are more than one X-assist menus, i.e. menus which start with the name of the current application. Clicking on this menu shows a command "Auto-Hide Others". Uncheck this command, and all will work as it should.

I am not sure if it is X-assist or some other application which provides this menu. But for me, I have this menu, and it solves this problem!
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.