Someone please help (cable damaged)

Discussion in 'iMac' started by HappyHammer7, Jul 31, 2010.

  1. HappyHammer7 macrumors newbie

    Joined:
    Feb 2, 2010
    #1
    I upgraded my hard drive to 1tb in my iMac 20" aluminium desktop. Everything went well, tested before I put it back together and all was well. Then I done the most stupidest thing putting it back together. The LCD temperature sensor cable must of dropped down when I put the metal brazil back on, then I screwed right through it, splitting the cable. Now, the fan starts up really loudly and I am getting no picture. I know I need a new cable but I have searched everywhere but I cannot find one. I don't really want to get it professionally repaired, as it will cost a fortune for what only is a single cable.

    Any advice on where I go from here will be much appreciated.
     
  2. ReggaeFire macrumors 6502

    Joined:
    Mar 19, 2003
    #2
  3. HappyHammer7 thread starter macrumors newbie

    Joined:
    Feb 2, 2010
    #3
    Thanks for the response. I managed to use some other wire, strip it and connect the snapped wire together, by twisting them and using insulation tape to seal the connection. Worked like a charm but I am only using this as a short term solution. I managed to find the part on macrecycling.com and and ordered that to fix it. Cost me $60 as I am based in the UK but would of been much more expensive taking it to Apple. That is certainly a mistake I will NEVER make again, so on a positive note, its a learning experience.
     

Share This Page