Something is seriously wrong with battery life on my 6s

Discussion in 'iPhone' started by Ghost31, Apr 16, 2016.

  1. Ghost31 macrumors 68000

    Ghost31

    Joined:
    Jun 9, 2015
    #1
    My phone was fully charged at 7pm. All I've done is some light texting and it's already at 26%? How is that even remotely possible? Ever since the last 9.3 update my battery has been total crap
     

    Attached Files:

  2. Shirasaki macrumors 603

    Shirasaki

    Joined:
    May 16, 2015
    #2
    4 hrs for 70% drop. I can only reach such battery drop by playing freeblade continuously.
    Maybe you should check which app takes your battery the most.
     
  3. rodpascoe macrumors regular

    rodpascoe

    Joined:
    Jun 19, 2006
    Location:
    Newquay, Cornwall
    #3
    Yeah, Shirasaki is right, check your usage in settings and it will display the apps in order of battery usage. You might have a rouge one draining power.
     
  4. Newtons Apple macrumors P6

    Newtons Apple

    Joined:
    Mar 12, 2014
    Location:
    Jacksonville, Florida
    #4
    The OP has been around here long enough to know that.
     
  5. Zeos macrumors 6502

    Joined:
    Jan 24, 2008
    #5
    Try disabling Safari syncing under iCloud settings.
     
  6. The Game 161 macrumors G5

    The Game 161

    Joined:
    Dec 15, 2010
    Location:
    UK
    #6
    what % is using the most battery and that should be your answer
     
  7. Mlrollin91 macrumors G4

    Mlrollin91

    Joined:
    Nov 20, 2008
    Location:
    Ventura County
    #7
    You keep posting this in battery threads, but there is absolutely no proof that that is the issue. I have had this turned on for years now and have seen no negative impact on battery life. Also, if you turn this off, you lose a lot of functionality. iCloud tabs and bookmark syncing to name some.
     
  8. CooKieMoNs7eR macrumors 68000

    CooKieMoNs7eR

    Joined:
    Nov 18, 2009
  9. kevink2 macrumors 65816

    Joined:
    Nov 2, 2008
    #9
    My battery is flakey recently. It may have been longer, and I just didn't notice, since I keep it in a battery case. But one day I forgot to charge it, and was running off of just the internal battery. Made quick drops from 30-17-2, and shut down doing an app upgrade. Plug it in, immediately up to about 15%. So I think there is an issue with the battery. I'm taking it into an Apple store Saturday. (This is an iPhone 6).
     
  10. Carmenia83 macrumors 6502

    Joined:
    Feb 25, 2012
    #11
    I don't know what happened to OP, but I've been having the same issue since 9.3.2 came out. Today my 6s was down to 3% by the time I came home for lunch with normal use. Some days the battery starts rapidly draining 2-3% per minute while Im using it for Facebook or safari browsing. A few days ago it went down to 19% and I did a hard reset and when the phone powered back on it was at 34%. I've checked the battery stats in settings and nothing is running abnormally. I did a DFU restore but restored from my iCloud backup because I don't want to lose all the saved app data. The problem still persists. Unfortunately, it is not consistent enough to make a Genius Bar appointment as some days its perfectly normal. I have background app refresh off and mail set to fetch hourly, as I've always had. Any suggestions?
     
  11. M. Gustave macrumors 68000

    M. Gustave

    Joined:
    Jun 6, 2015
    Location:
    Grand Budapest Hotel
    #12
    Bingo!
     
  12. Carmenia83 macrumors 6502

    Joined:
    Feb 25, 2012
    #13
    I wish it were that simple. Ive been using the Facebook app for years. This happened the day I updated to 9.3.2. I tried removing the Facebook app and using safari, same thing. I tried disabling LTE and only using 3G, same. If I open the camera to take a picture it costs me about 4-5% by the time I've taken the photo. Theres an iOS issue going on but I don't know how to track it down. Anyone proficient in Xcode that can talk me through figuring out whats going on. I really don't want to go all the way to the closest Apple Store for them just to tell me to turn off all the things the phone is supposed to do.
     
  13. M. Gustave macrumors 68000

    M. Gustave

    Joined:
    Jun 6, 2015
    Location:
    Grand Budapest Hotel
    #14
    I don't see that you have a choice. If everyone running 9.3.2 had this problem, there would be posts everywhere about it. I'm getting great battery life on 9.3.2.
     
  14. akash.nu macrumors 68020

    akash.nu

    Joined:
    May 26, 2016
    #15
    I'm on an iPhone 6 as well and have faced the same issue but I've managed to sort it out by doing a battery power cycle and then restoring the device and setting it up as new.
     

Share This Page