sometimes my MBA 2012 can't connect to the wifi internet

Discussion in 'MacBook Air' started by jetlagged, Oct 13, 2016.

  1. jetlagged macrumors 6502

    Joined:
    Sep 6, 2012
    #1
    Hello, I’m wondering if my Macbook Air 2012 13” is nearing the end of its life?



    The reason I ask is because when I turn on my computer from sleep mode to use it, sometimes it doesn’t connect to the wifi network that we have. it would search for it, after a while, the wifi signal is just greyed out. we use the ATT home wifi. sometimes i'll go for week and it will connect with no problems, then alll of a sudden like today it starts acting up and cant connect to the network.



    my iPhone, and iPad have no problems connecting the internet.



    it’s kind of annoying, because I never know if my laptop will connect to the network or not. i’m not a tech guy, but i’m thinking there’s a problem with the wifi thingy inside the computer. maybe it’s old or damaged.



    i’ve tried all sorts of things, restarting my computer sometimes help, but sometimes it doesn’t.



    what could be wrong with it?

    as i finish typing it, it finally connected. i had to hover the mouse cursor to the top right of the screen where the wifi on/off is at. I turned it off, and back on. now i’m connected. it took 30 minutes. but sometimes this method doesnt work.
     
  2. Snappers macrumors member

    Joined:
    Aug 31, 2016
    #2
    --- Post Merged, Oct 14, 2016 ---
    Sorry about the above post, MR wouldn't let me edit that. Ok, so here is what I originally meant to post...

    It could be a Keychain related problem or something in your Network settings in System Preferences.

    Try going into System Preferences, Network, select Wi-Fi in the left hand column, then click Advanced. Find your wi-fi in Network Name and select it, then click the - button to delete it. Click OK then click Apply in the Network window.

    Next, in the Network window, go to Network Name and select your wi-fi SSID and try to connect to it, enter your wi-fi password.

    If that works, great. If not, check to make sure your TCP/IP is set to Using DHCP. If that is set right, the next thing you might want to do is delete your airport network password from Keychain Access, and also check for/and delete duplicates of that network password. Once you delete that from the Keychain, you will have to reconnect to the wifi and enter your password again and make sure you save it to your Keychain.

    Hope this helps!
     
  3. jetlagged, Oct 16, 2016
    Last edited: Oct 16, 2016

    jetlagged thread starter macrumors 6502

    Joined:
    Sep 6, 2012
    #3
    Thanks, i tried everything that you suggested. but it didnt work. looks like i'm not the only one who has this problem when i did a google search. i'm beyond frustrated. my dad's macbook pro 2012 seems to work fine. but i dont udnerstand why my mba 2012 has problems connecting to the wifi. it takes a while.

    so right now i'm using the guest wifi name through the same wifi network, but have the SSID hidden because it's an open network with no password. seems to be working fine for now. it takes about 1 minute to connect to the open network i created. but it's okay.
     
  4. Rok73 macrumors 65816

    Rok73

    Joined:
    Apr 21, 2015
    Location:
    Planet Earth
    #4
    I'd highly recommend to find a different solution than an open network. I can easily find hidden SSIDs with the appropriate software and so can everyone else.
     
  5. Snappers macrumors member

    Joined:
    Aug 31, 2016
    #5
    Oh wow, I do understand your frustration. Even with open network, it is slow to connect. Not good. What happens when you try to connect to other wi-fi networks besides those from your home router, like neighbor/friend/hotspot? Same problem?

    Trying to isolate possible causes, such as the router you are currently using. I know you say other devices in your household connect to the same network without problems, but it is not to say there is something going on in that router that is preventing your Air from connecting properly, like some firewall setting or DHCP/MAC conflict. I've seen DHCP conflicts cause delay in my Air connecting to a network before, so that is what I am getting at here.

    Trying to exhaust all external issues first before concluding it is the Air itself. What is your Air's IP compared to your router's IP? You don't have to post that info here, but just check to make sure it is on the same scheme. Can you check your router to see what DHCP settings are in place and what IP range is available? Are there any conflicts with your IP and what the router shows? Is your router set to static IP for your Air? If so, is the static IP different from what your actual IP is? Does your Air's MAC match what your router shows as the MAC for your IP?
     

Share This Page