Sometimes Screen Does Not Lock After Closing Lid

Discussion in 'MacBook Pro' started by imakepizza, Dec 14, 2013.

  1. imakepizza macrumors newbie

    Joined:
    Nov 30, 2013
    #1
    Title says it all. Occasionally, I can open the lid without seeing a password prompt. This is on the newest rMBP 13".
     
  2. raptor402 macrumors 6502

    Joined:
    Jun 30, 2011
    #2
    Go to System Preferences > Security & Privacy > General. The second option states, "Require password {drop down menu} after sleep or screen saver begins"

    Select immediately in the drop down menu.

    I hope this helps.

    Regards
    Raptor
     
  3. bobcan macrumors 6502a

    bobcan

    Joined:
    Jan 8, 2007
    Location:
    Sunny but Cold.. Canada
    #3
    Or, you can 'LOCK' it yourself with the Hot Corners set-up, requiring Password to Unlock.. (I have set to Scroll to Upper Right Corner on mine) and to SLEEP it I use the manual 'Option+Command+Eject' method, as I have gotten used to for years now.. Both these seem to work pretty much flawless for me!!
     
  4. imakepizza thread starter macrumors newbie

    Joined:
    Nov 30, 2013
    #4
    Thanks but I am trying to troubleshoot, not work around. Raptor, I do have the setting on. Most of the time the screen is locked, but sometimes it stays unlocked. This should obviously not be happening so I'm going here for troubleshooting advice.
     
  5. raptor402 macrumors 6502

    Joined:
    Jun 30, 2011
    #5
    So it's not a timer issue? As long as the timer is set to "immediately", it should lock as soon as the lid closes.

    Do you get the sleep indicator when you close the lid (at times when it doesn't lock)?
     
  6. imakepizza thread starter macrumors newbie

    Joined:
    Nov 30, 2013
    #6
    I have it set for five seconds. Most of the time this works, but, for example today, I came home and opened it without a password prompt. I'm looking for technical advice on how to fix this.
     
  7. imakepizza thread starter macrumors newbie

    Joined:
    Nov 30, 2013
  8. Thordoubt macrumors newbie

    Joined:
    Mar 13, 2009
    #8
    You are not alone.... I have also noticed this on my 13" rMBp. Checked all the settings and they are set to a 5 second wait. Once this has happened, it will never lock itself automatically again without a reboot.
     
  9. ignusb macrumors newbie

    Joined:
    May 6, 2014
    #9
    I've had this issue a few times in the past month.

    Latest rMBP 13", OS X 10.9.2.

    My timer is set to require password 5 seconds after sleep or screen saver begins.

    I've had this happen on three occasions; one where the laptop was closed and sleeping for 8 hours, one where the laptop was closed and sleeping for 14 hours, the other where the laptop was closed and sleeping for 8 hours while plugged in to AC.
     
  10. The Man macrumors 6502

    Joined:
    Jul 7, 2004
    #10
    Yeah, me too. This is not good and I don't know why it happens.
     

Share This Page