Songs not showing in "Artist" section...HELP

Discussion in 'iPod' started by mattnotis, Jul 2, 2010.

  1. mattnotis macrumors regular

    Joined:
    May 9, 2010
    #1
    For some reason, certain artists and albums only appear in the "Songs" and "Albums" menus but are nowhere to be found when I look for the particular artist in the "Artist" section. Why does this happen and how can I fix it? The files are on the iPod but for some reason won't show up in all of the menus. It's really bizarre.
     
  2. Cinematographer macrumors 6502a

    Cinematographer

    Joined:
    Sep 12, 2005
    Location:
    far away
    #2
    Are these songs set to be part of a compilation?
     
  3. Labaguette macrumors regular

    Joined:
    Feb 21, 2010
    Location:
    Good ol' Germany
    #3
    Also, please remember that initially (without configuring it) e.g. 'The Hives' are listed under 'H' instead of 'T'.
     
  4. GroundLoop macrumors 68000

    GroundLoop

    Joined:
    Mar 21, 2003
    #4
    I know that I am resurrecting an old thread, but I seem to be running into the same issue. I have several artists that are not showing up on my 5.5G iPod, but when I go to the albums/songs, they are there. I primarily use this ipod in the car and navigate through steering wheel controls and constantly switching from artist to album mode on the steering wheel is a pain in the ass. I have tried restoring to no avail.

    Has anyone who had this issue ever get it resolved? How did you do it?

    GL
     
  5. philden macrumors newbie

    Joined:
    Jul 28, 2010
    #5
    When your iPod is connected to iTunes, view your iPod library and in 'column browser' make sure that 'group compilations' is unchecked.

    This might fix it.
     

Share This Page