Songs not showing up under artist

Discussion in 'iPod touch' started by stubie, Mar 26, 2012.

  1. stubie macrumors newbie

    Joined:
    Mar 26, 2012
    #1
    Recently, the songs I have been putting on my iTouch 4G has not been showing up under the Artist section, but will show up under the Album section and I can search for them on my iTouch. Has anybody had this problem before and any tips to fix this??
     
  2. thegreati macrumors regular

    Joined:
    Feb 22, 2012
    #2
    Sometimes songs, usually pirated music don't have anything inside the Artist and Track name section (Either in get info for mac, or properties for windows) so the tracks are inside the ipod, just not under the artist because the track itself doesn't know where to be placed.

    Hope this makes sense :)
     
  3. stubie thread starter macrumors newbie

    Joined:
    Mar 26, 2012
    #3
    They were mixtapes from a legitimate site that have the artist, track names and even the album cover artwork in iTunes, so I don't think that is the case. I even updated the Album Artist column and it is still not showing up under artist.
     
  4. likethesoup2 macrumors 6502a

    Joined:
    Mar 29, 2011
    Location:
    Orlando, Florida
    #4
    If you go into itunes, highlight one of the problem songs, then go under file - get info; you can modify how they're labeled. I'm quite sure that's what's wrong.

    Warning - it can get QUITE tedious.
     
  5. GroundLoop, Mar 31, 2012
    Last edited: Mar 31, 2012

    GroundLoop macrumors 68000

    GroundLoop

    Joined:
    Mar 21, 2003
    #5
    For the problem songs, under "Get Info" -> "Info", uncheck the "Part of a Compilation" box.

    You can do them all very quickly by creating a smart playlist filtering on Compilation = true.

    Warning: this could add tons of "new" artists.

    GL
     
  6. funmuncher5 macrumors newbie

    Joined:
    Apr 4, 2011
    #6
    I had this same problem and none of the things here worked. Here's what worked for me: get info>sorting>Sort artist then type the artist's name and it should work.
     

Share This Page