Songs not showing up under Artists in iPod, but are under Songs?

Discussion in 'iPod' started by Khryz, Aug 22, 2007.

  1. Khryz macrumors 6502a

    Joined:
    Jan 7, 2007
    #1
    Just bought a new 30GB Video iPod. To be quick, a few songs that are on my iTunes do not show up in the Artist folder when I search for it that way on my iPod. However, they are there when I search for it under Songs.

    When I connect my iPod and check the songs that way, it says they are there. Why are they not showing up when I find them under Artist? Only 1 of the songs for the band shows up and they are all in the same folder.

    This is really weird .. Can anyone help?

    Thanks!
     
  2. Draythor macrumors 6502

    Draythor

    Joined:
    Sep 12, 2006
    Location:
    Exeter University, UK
  3. Khryz thread starter macrumors 6502a

    Joined:
    Jan 7, 2007
    #3
    Thank you for your quick reply but that did not help, it did make my iTunes more neat. But this is when I search for it on my iPod, not my iTunes. In my iTunes everything looks fine. But if I search for a specific song on my iPod by going Music > Artists > Band > only 1 song shows up. But if I go Music > Songs > I can find the song from the band even though it doesn't show up under the band in Artists.

    Sorry if my question was confusing. I have no idea why it isn't there but .. it is.

    EDIT: Nevermind, I just had to make all the songs have the same Album name and whatnot, weird that never happened before on my older iPod or my PC iTunes ..
     
  4. Boulderer2001 macrumors member

    Joined:
    Jul 20, 2007
    #4
    I have had the same problem before. You can try editing in i-tunes the track information. Sometimes it is backwards. Also I think songs if downloaded off limewire etc... show up weird because of copyright problems. I have had to put a few songs in a playlist to find them easily because of this problem.
     

Share This Page