Sony Ericsson 850i connectivity to mac difficulties.

Discussion in 'Mac Basics and Help' started by harald77, Mar 11, 2009.

  1. harald77 macrumors newbie

    Joined:
    Mar 14, 2008
    #1
    Hi all; this phone only comes with p.c.software. I am going round in circles trying to get it connected to my mac. Sony say apple wont let sony give the software away with the phone! Can this be true?! Can someone point me in the right direction please?
     
  2. Ubuntu macrumors 68000

    Ubuntu

    Joined:
    Jul 3, 2005
    Location:
    UK/US
    #2
    Unfortunately there is no official software at this time. Can I ask what you want to connect the phone to your mac for? When I had a Sony Ericsson I just used the Bluetooth, and it worked fine.
     
  3. harald77 thread starter macrumors newbie

    Joined:
    Mar 14, 2008
    #3
    I just want to upload pics really, from phone to mac.
     
  4. Ubuntu macrumors 68000

    Ubuntu

    Joined:
    Jul 3, 2005
    Location:
    UK/US
    #4
    You have a mac with bluetooth, right? Its been a while since I've had a Sony Ericsson, but click the Bluetooth icon on the menu bar, on your mac, and select Browse Device. It'll then search for devices, and you'll have to pair them, and thats it.
     
  5. harald77 thread starter macrumors newbie

    Joined:
    Mar 14, 2008
    #5
    Errrrr. I've never used bluetooth on it. How do I go about that"? theres nothing on my toolbar.
     
  6. Ubuntu macrumors 68000

    Ubuntu

    Joined:
    Jul 3, 2005
    Location:
    UK/US
    #6
    Well, if your mac has bluetooth, go to the Apple Menu, then System Preferences, and look under the Hardware section, or type bluetooth in the search field.

    Then tick the box "Show Bluetooth status in the Menu bar".
     
  7. instaxgirl macrumors 65816

    instaxgirl

    Joined:
    Mar 11, 2009
    Location:
    Edinburgh, UK
    #7
    Have you tried just plugging it in and launching iphoto? My SE k800i used to show up as a camera.

    I used bluetooth most of the time anyway though rather than have another cable around.
     
  8. harald77 thread starter macrumors newbie

    Joined:
    Mar 14, 2008
    #8
    Thnx, but when i do that it shows green for internet connected
    and red for internal modem ?
     
  9. LeahM macrumors 6502a

    LeahM

    Joined:
    Mar 18, 2008
    #9
    Did you get a USB cord with it? If so you don't really need the software, you can just drag it into the appropriate files.
     
  10. harald77 thread starter macrumors newbie

    Joined:
    Mar 14, 2008
    #10
    I cant find bluetooth, but you made me think. my last 800 loaded straight up, this one wont.

    HOWEVER, I just tried 'mass file storage" and its worked!!

    Thank you all for indulging a halfwit.
     

Share This Page