Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

johannnn

macrumors 68020
Original poster
Nov 20, 2009
2,238
2,383
Sweden
I have a pair of Sony WH-1000XM3, and use them daily with my 2017 27" iMac. Whenever I'm going away for a break, I hold the ON/OFF button on the headphones to turn it off to save battery. I like that whenever I hop the button again, it not only turns on, but also automatically pairs with the iMac. However, sporadically, like once every two days, when it pairs I only get audio from the right ear. Then I have to launch System Preferences and go into Audio and move the balance to the middle.

What can cause this? Any swipe-gesture on the headphones that I'm not aware of? Any macOS bug that I'm not aware of?
 

henrymyf

macrumors regular
Dec 2, 2015
142
58
When the left audio is muted, is the balance slide of the Audio on the left most position?
 

johannnn

macrumors 68020
Original poster
Nov 20, 2009
2,238
2,383
Sweden
The slider is on the right most position (i.e. 100% in the right ear).

So moving the slider back to the middle solves the audio.

I just don’t understand why it happens sometimes.
 

henrymyf

macrumors regular
Dec 2, 2015
142
58
The slider is on the right most position (i.e. 100% in the right ear).

So moving the slider back to the middle solves the audio.

I just don’t understand why it happens sometimes.
It seems to be a software problem, that the computer received a message from the earphone that the balance is adjusted to the right. Is there any mechanism that the balance could be adjusted on the phone itself?
 

johannnn

macrumors 68020
Original poster
Nov 20, 2009
2,238
2,383
Sweden
It seems to be a software problem, that the computer received a message from the earphone that the balance is adjusted to the right. Is there any mechanism that the balance could be adjusted on the phone itself?
No mechanism as far as I know (https://helpguide.sony.net/mdr/wh1000xm3/v1/en/contents/TP0001703116.html)

It only happens occasionally when I connect the head phones. Never occasionally while them being connected.

And it has never happened with my AirPods.
 

henrymyf

macrumors regular
Dec 2, 2015
142
58
No mechanism as far as I know (https://helpguide.sony.net/mdr/wh1000xm3/v1/en/contents/TP0001703116.html)

It only happens occasionally when I connect the head phones. Never occasionally while them being connected.

And it has never happened with my AirPods.
You are right. Apple's product, no matter how small it is, seldomly fails you.

I used to be an all-Apple-user, until I realized Apple is vastly used. Now I am using a Windows PC and an Android phone, and a SONY WF-1000XM3, because I thought these combination would make me look cool, but I regret very much. My wifes AirPods are always online. I guess I will switch back to Apple sooner or later.
 

coffeeplease

macrumors 6502
Sep 28, 2019
468
328
I used ballast on my old 2015 MBP since I'd always run into this issue with AirPods (unsure if it happened to my WH-1000XM3). It'll automatically re-center the audio balance on when connecting your headphones. They seemed to have stopped developing it and suggest using Balance Lock so you can give that a try. I thought I had re-installed this program when I got my 2020 MBP, but turns out I didn't and have not ran into this issue at all on Catalina and Big Sur. Perhaps it is hardware related?
 

collin_

macrumors 6502a
Nov 19, 2018
582
887
Hi johannnn,

I was just going to make a thread about this as I have the same issue. The balance slider for my Sony WH-1000XM3s occasionally moves to the left or right for seemingly no reason. The first time it happened, I genuinely thought my headphones were broken until I discovered the slider. It's easy to correct, but I don't understand why it happens in the first place.

Another thing is that the volume randomly changes to full blast sometimes when the headphones are switched from my phone to my computer. I never listen to music at >60% volume, so it's incredibly jarring. It's also impossible to adjust the volume until the headphones actually start playing something. I wish there was a fix for these issues. Let me know if you find out anything.

EDIT: I am still on Catalina btw. Not sure if this is fixed in Big Sur.
 

johannnn

macrumors 68020
Original poster
Nov 20, 2009
2,238
2,383
Sweden
Hi johannnn,

I was just going to make a thread about this as I have the same issue. The balance slider for my Sony WH-1000XM3s occasionally moves to the left or right for seemingly no reason. The first time it happened, I genuinely thought my headphones were broken until I discovered the slider. It's easy to correct, but I don't understand why it happens in the first place.

Another thing is that the volume randomly changes to full blast sometimes when the headphones are switched from my phone to my computer. I never listen to music at >60% volume, so it's incredibly jarring. It's also impossible to adjust the volume until the headphones actually start playing something. I wish there was a fix for these issues. Let me know if you find out anything.

EDIT: I am still on Catalina btw. Not sure if this is fixed in Big Sur.
I only use them for my Mac, so I have no experience switching between iOS and macOS unfortunately.

Interestingly, I've never had this issue since I made this post. No idea why.

I'm on Big Sur now, but only since 2-3 weeks ago. So the problem was "fixed" for me in Catalina as well.
 

Rubycas

macrumors newbie
May 23, 2024
1
0
Hi johannnn,

I was just going to make a thread about this as I have the same issue. The balance slider for my Sony WH-1000XM3s occasionally moves to the left or right for seemingly no reason. The first time it happened, I genuinely thought my headphones were broken until I discovered the slider. It's easy to correct, but I don't understand why it happens in the first place.

Another thing is that the volume randomly changes to full blast sometimes when the headphones are switched from my phone to my computer. I never listen to music at >60% volume, so it's incredibly jarring. It's also impossible to adjust the volume until the headphones actually start playing something. I wish there was a fix for these issues. Let me know if you find out anything.

EDIT: I am still on Catalina btw. Not sure if this is fixed in Big Sur.
Hi mine have this problem constantly, only playing in the left ear and then every now and then they will suddenly play in the right. How do i fix this problem please, can i do it myself? Thanks
 

collin_

macrumors 6502a
Nov 19, 2018
582
887
Hi mine have this problem constantly, only playing in the left ear and then every now and then they will suddenly play in the right. How do i fix this problem please, can i do it myself? Thanks
Hi Ruby,

I was able to remediate the unbalanced audio issue with Balance Lock on the Mac App Store. Here's the link.
 
  • Like
Reactions: Rubycas
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.