SOOOO Frustrated with Time Machine

Discussion in 'Mac Apps and Mac App Store' started by imahawki, May 2, 2011.

  1. imahawki macrumors 6502a

    Joined:
    Apr 26, 2011
    #1
    I've searched and tried every "fix" I've found on the internet to no avail. Time Machine keeps giving me the error "Unable to complete backup. An error occurred while creating the backup folder."

    I'm using an external USB 2.0 drive. I've reformatted the drive, I've repaired it, and I've added the drive to the "privacy" setting for finder since some people claimed that was the problem. I've done everything I can find on internet searches. Another important note is that whenever this happens, I'm unable to eject the drive normally. If I restart, it seems like the first backup runs fine.

    At this point I THINK this is related to the machine going to sleep during a backup. I've read that that is a problem too and if I've got a process running (hadbrake encodes) the backup will run multiple times in a row without error. But as soon as that process completes the next backup fails.

    If this is the case this is a major bug for crying out loud. How can I set my machine to never go to sleep at this point (Mac Mini running latest version of SL) so I can at least test. And if this ends up being the case, shame on Apple for such a blatant bug!
     
  2. Fishrrman macrumors G5

    Fishrrman

    Joined:
    Feb 20, 2009
    #2
    Suggestion:
    Download the free CarbonCopyCloner from bombich.com.

    Take a few mins and set it up.

    It will create BOOTABLE backups in POFF (plain ol' finder format).

    In a moment of extreme need, you will find out why this is a better way to backup your data....
     
  3. imahawki thread starter macrumors 6502a

    Joined:
    Apr 26, 2011
    #3
    Setting my computer to never sleep didn't fix it. I'm not really interested in using another program. TM should work. I'm a little stubborn and once I get something stuck in my craw I just want it to work, but on top of that, I actually LIKE the way TM works (when it works).

    It seems like I can consistently get a backup to run right after a reboot but it will inevitably fail after that first backup runs. I've reformatted the drive with no fix other than generating an extremely long initial backup. I've got two drives for offsite rotation and the error occurs with both. The drives weren't bought at the same time and aren't out of the same batch (in fact one is a WD Black and the other is a WD Green) so I'm not thinking its a disk issue.

    My computer is less than 90 days old. Should I call Apple?
     
  4. eccentricglow macrumors member

    eccentricglow

    Joined:
    Mar 16, 2010
    #4
    Troubles with Time Machine

    To be quite honest, Time Machine leaves a lot to be desired when it comes to error reporting when something goes wrong. I feel your frustration because I had the same problem a few months ago. I've found that looking at the console helps to determine what error occurred and then searching Google to see what the error means, and how to fix it. I think you can find the console in the utilities folder somewhere - can't exactly remember where it is.

    My problem with Time Machine was that my disk permissions were screwed up and so it wasn't copying the files nessessary to complete the back up - it would just quit. I would check to see if those were set correctly by going into info and reseting them. Might help.
     
  5. imahawki thread starter macrumors 6502a

    Joined:
    Apr 26, 2011
    #5
    I deleted my time machine preferences and started from scratch (full reset as its called). It backed up last night and then this morning it reported that the disk was full. It was more of an alert than an error. I said OK and started the next backup and it failed, same error. I've got 641GB of free space on the disk! My backup set is large but it should only be backing up the changes so it shouldn't be bombing out. Nothing on my computer changed over night (or sure as hell not 641GB worth of changes!
     
  6. imahawki thread starter macrumors 6502a

    Joined:
    Apr 26, 2011
    #6
    I'm still having no luck. How do I reset the disk permissions. I can see that they are set right, but I assume you mean something else by re-setting?

    I have tried every troubleshooting article I can find and basically if I unmount the drive and reboot, the first backup will always run but subsequent ones will always fail.
     
  7. Europe calling macrumors regular

    Europe calling

    Joined:
    Jun 27, 2007
    Location:
    The Netherlands
    #7
    I've read you can mount the sparse bundle that TM creates, and then run disk utility on that to repair permissions. It seems to have worked for people (can't remember the link, sorry)
     
  8. imahawki thread starter macrumors 6502a

    Joined:
    Apr 26, 2011
    #8
    I ended up sort of figuring out it. Its something to do with the Thermaltake BlacX dock. I plan on switching over to the Seagate Goflex drives when these fill up so I went ahead and bought the Firewire 800 dock and rigged up a shim so it can connect to a bare drive and ever since the backups have been running like clockwork. So it must have been the drive dock or the USB connection or something.
     

Share This Page